<!DOCTYPE html>
<html lang="en-GB">
<head><link rel="stylesheet" type="text/css" href="https://whatson.ae/wp-content/cache/minify/491f1.css" media="all" />
<meta charset="UTF-8">
<title>5 new and returning brunches to try in Dubai this weekend</title>
<meta name="keywords" content="" />

<meta name="viewport" content="width=device-width, user-scalable=no" />

<meta name="description" content="If you&#039;re looking for somewhere to brunch this weekend, we&#039;ve got you covered with some brand new brunches and some old returning favorites" />
<link rel="original-source" href="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="5 new and returning brunches to try in Dubai this weekend" />
<meta property="og:description" content="Who&#039;s ready for the weekend?" />
<meta property="og:url" content="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" />
<meta property="og:site_name" content="What&#039;s On" />
<meta property="article:publisher" content="https://www.facebook.com/WhatsOnDubai" />
<meta property="article:tag" content="Brunch" />
<meta property="article:tag" content="dubai brunch" />
<meta property="article:tag" content="new brunch" />
<meta property="article:tag" content="new brunch dubai" />
<meta property="article:section" content="Eat &amp; Drink" />
<meta property="article:published_time" content="2021-09-16T07:55:32+00:00" />
<meta property="fb:app_id" content="521837017887988" />
<meta property="og:image" content="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-facebook.jpg" />
<meta property="og:image:secure_url" content="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-facebook.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="627" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="If you&#039;re looking for somewhere to brunch this weekend, we&#039;ve got you covered with some brand new brunches and some old returning favorites" />
<meta name="twitter:title" content="5 new and returning brunches to try in Dubai this weekend" />
<meta name="twitter:site" content="@WhatsOnDubai" />
<meta name="twitter:image" content="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-facebook.jpg" />
<meta name="twitter:creator" content="@WhatsOnDubai" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://whatson.ae/#website","url":"https://whatson.ae/","name":"What&#039;s On","description":"Things to do in Dubai &amp; the UAE","potentialAction":{"@type":"SearchAction","target":"https://whatson.ae/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/#primaryimage","url":"https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-feat.jpg","width":800,"height":440,"caption":"5-new-brunches-dubai"},{"@type":"WebPage","@id":"https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/#webpage","url":"https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/","inLanguage":"en-GB","name":"5 new and returning brunches to try in Dubai this weekend","isPartOf":{"@id":"https://whatson.ae/#website"},"primaryImageOfPage":{"@id":"https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/#primaryimage"},"datePublished":"2021-09-16T07:55:32+00:00","dateModified":"2021-09-16T07:55:32+00:00","author":{"@id":"https://whatson.ae/#/schema/person/3aba97a61c9af35278ecb0770a9431ed"},"description":"If you're looking for somewhere to brunch this weekend, we've got you covered with some brand new brunches and some old returning favorites"},{"@type":["Person"],"@id":"https://whatson.ae/#/schema/person/3aba97a61c9af35278ecb0770a9431ed","name":"Lauren Fletcher","image":{"@type":"ImageObject","@id":"https://whatson.ae/#authorlogo","url":"https://secure.gravatar.com/avatar/14b16148f6ba078bfb8c537c9964755d?s=96&d=mm&r=g","caption":"Lauren Fletcher"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="What&#039;s On &raquo; 5 new and returning brunches to try in Dubai this weekend Comments Feed" href="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/whatson.ae\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.9"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/df983.js"></script>
<link rel='https://api.w.org/' href='https://whatson.ae/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://whatson.ae/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://whatson.ae/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.9" />
<link rel='shortlink' href='https://whatson.ae/?p=209438' />
<link rel="alternate" type="application/json+oembed" href="https://whatson.ae/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhatson.ae%2F2021%2F09%2F5-new-and-returning-brunches-to-try-in-dubai-this-weekend%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://whatson.ae/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhatson.ae%2F2021%2F09%2F5-new-and-returning-brunches-to-try-in-dubai-this-weekend%2F&#038;format=xml" />
<meta property="fb:pages" content="133671683313479" />
<meta property="ia:markup_url" content="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/?ia_markup=1" />
<style id="ctcc-css" type="text/css" media="screen">
				#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ddd;
					position: fixed;
					left: 0;
					bottom: 0;
					width: 100%;
					background-color: #000000;
				}
				#catapult-cookie-bar a {
					color: #fff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: #000000;
				}
				button#catapultCookie {
					background:#ffffff;
					color: #000000;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ddd;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style>

<meta name="wp-parsely_version" id="wp-parsely_version" content="2.0" />
<script type="application/ld+json">
		{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/whatson.ae\/2021\/09\/5-new-and-returning-brunches-to-try-in-dubai-this-weekend\/"},"headline":"5 new and returning brunches to try in Dubai this weekend","url":"https:\/\/whatson.ae\/2021\/09\/5-new-and-returning-brunches-to-try-in-dubai-this-weekend\/","thumbnailUrl":"https:\/\/whatson.ae\/wp-content\/uploads\/2021\/09\/5-new-brunches-dubai-feat.jpg","image":{"@type":"ImageObject","url":"https:\/\/whatson.ae\/wp-content\/uploads\/2021\/09\/5-new-brunches-dubai-feat.jpg"},"dateCreated":"2021-09-16T07:55:32Z","datePublished":"2021-09-16T07:55:32Z","dateModified":"2021-09-16T07:55:32Z","articleSection":"Brunch","author":[{"@type":"Person","name":"Lauren Fletcher"}],"creator":["Lauren Fletcher"],"keywords":["brunch","dubai brunch","new brunch","new brunch dubai"],"publisher":{"@type":"Organization","name":"What&#039;s On","logo":{"@type":"ImageObject","url":""}}}
		</script>


<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>

<script type='text/javascript'>
  fbq('init', '301969470674972', {}, {
    "agent": "wordpress-5.3.9-3.0.0"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>

<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=301969470674972&ev=PageView&noscript=1" />
</noscript>

<style>.twentytwenty-container { margin-bottom: 5px ; background-color:#666666;}
    .smallcaption { font-size: 11px; color: #666666; margin-bottom: 15px;}
    .instagram-media { width:100%; }
    </style>
<link rel="stylesheet" href="https://whatson.ae/wp-content/themes/whatson-grow/js/royalslider/skins/default/rs-default.css">
<script src="https://whatson.ae/wp-content/themes/whatson-grow/js/royalslider/jquery.royalslider.min.js"></script>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/ae1ea.js"></script>
<style>.royalSlider {
      width: 100%;
      height: 412px;
    }</style>

<script type="text/javascript">
		window.bk_async = function() {
		 // ALLOW MULTIPLE CALLS/SINGLE PAGE APPS
		bk_allow_multiple_calls=true; bk_use_multiple_iframes=true ;
		 // <optional> PHINTS : Declare variables about this page (or user)
		bk_addPageCtx('page_type', 'Article'); // example phint (change to your own useful variabes)
		bk_addPageCtx('section', 'Brunch,Eat &amp; Drink'); // example phint (change to your own useful variabes)
		bk_addPageCtx('article_ID', '209438'); // article_ID
		bk_addPageCtx("article_name", "5 new and returning brunches to try in Dubai this weekend"); // headline of article
		bk_addPageCtx("city", "Dubai"); // City		
		bk_addPageCtx("tag", "Brunch, dubai brunch, new brunch, new brunch dubai, "); // Tags		 
		 
		  // Send Data
		BKTAG.doTag(43849, 4);  // change "ENTER CONTAINER ID HERE" to the container ID/Site ID you want to use
		};
		(function() {
		  var scripts = document.getElementsByTagName('script')[0];
		  var s = document.createElement('script');
		  s.async = true;
		  s.src = "//tags.bkrtx.com/js/bk-coretag.js";
		  scripts.parentNode.insertBefore(s, scripts);
		}());
	</script>

<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/ff6a4.js"></script>

<script type="text/javascript">
	var _elqQ = _elqQ || [];
	_elqQ.push(['elqSetSiteId', '1244214268']);
	_elqQ.push(['elqTrackPageView']);

	(function () {
	    function async_load() {
	        var s = document.createElement('script'); s.type = 'text/javascript'; s.async = true;
	        s.src = '//img04.en25.com/i/elqCfg.min.js';
	        var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
	    }
	    if (window.addEventListener) window.addEventListener('DOMContentLoaded', async_load, false);
	    else if (window.attachEvent) window.attachEvent('onload', async_load);
	})();
</script>

<script id="parsely-cfg" data-parsely-site="whatson.ae" src="//cdn.parsely.com/keys/whatson.ae/p.js"></script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-13044993-17"></script>
<script>
        window.dataLayer = window.dataLayer || [];
        function gtag(){dataLayer.push(arguments);}
        gtag('js', new Date());

        gtag('config', 'UA-13044993-17');
    </script>
<link href="https://fonts.googleapis.com/css?family=Lato:400,700" rel="stylesheet">
<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') +
                    '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
            })();
        </script>
<script type='text/javascript'>
    var skinAd;
    var lbAd;
    var mobLbAd;
    var catfishAd;
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {

googletag.defineSlot('/21835097498/WhatsOn_Eat_LBBB', [[728, 90], [970, 250]], 'div-gpt-ad-1564911829270-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_Eat_MPU_ATF', [300, 250], 'div-gpt-ad-1594287406506-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_Eat_MPU', [300, 250], 'div-gpt-ad-1564911876216-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_Eat_HP', [300, 600], 'div-gpt-ad-1564911910443-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_Eat_Skyscraper', [160, 600], 'div-gpt-ad-1601453825783-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_Eat_Skyscraper', [160, 600], 'div-gpt-ad-1601453825783-1').addService(googletag.pubads());
googletag.pubads().setTargeting('Interests', ['Brunch' , 'Eat &amp; Drink' ]);    googletag.pubads().disableInitialLoad();
    googletag.pubads().enableSingleRequest(); 
    googletag.pubads().collapseEmptyDivs(); 
    googletag.enableServices();
    googletag.pubads().refresh();

    googletag.pubads().addEventListener('slotRenderEnded', function(event) {
        console.log('Creative with id: ' + event.creativeId +
        ' is rendered to slot of size: ' + event.size[0] + 'x' + event.size[1]);

        if(event.size[0] == 728 ){
            $('.header__ad-leader-board').css('height', event.size[1]);
        }

        if(event.size[0] == 970 ){
            $('.header__ad-leader-board').css('height', event.size[1]);
            $('.header').addClass('billboardAd');
        }

    });
    
});
</script>
<style type="text/css">
    .twentytwenty-container img { margin: 0 0; }
    .follow-us__each { margin: 3px; }
</style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-209438 single-format-standard">
<script type="text/javascript">
        var ajaxUrl = 'https://whatson.ae/wp-admin/admin-ajax.php';
        var baseUrl = 'https://whatson.ae';
        var tempUrl = 'https://whatson.ae/wp-content/themes/whatson-grow';
    </script>
<div class="wo__container">
<div class="wrapper" id="wrapper">

<header class="header header--desktop">
<div class="header--desktop__inner">
<div class="header__top">
<div class="header__top__flex-row  max-width">
<div class="header__logo__flex-row">
<div class="header__logo-wrapper">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="250" alt="logo icon"></a>
</div>
<div class="header__ad-leader-board">
<div class="header_ad-728x90">

<div id='div-gpt-ad-1564911829270-0'>
<script>
                                            googletag.cmd.push(function() {
                                                googletag.display('div-gpt-ad-1564911829270-0'); 
                                            });
                                        </script>
</div>
</div>
</div>
</div>
<div class="header__signup">
<a href="">Signup & Customize</a>
</div>
</div>
</div>
<div class="header__bottom">
<div class="header__bottom__flex-row  max-width">
<div class="header__nav">
<ul class="header__nav__list">
<li class="logo__inline">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="100" alt="logo icon"></a>
</li>
<li class="header__nav__list__item "><a href="/section/news/">NEWS</a></li>
<li class="header__nav__list__item "><a href="/section/eat/">EAT & DRINK</a></li>
<li class="header__nav__list__item "><a href="/section/things-to-do/">THINGS TO DO</a></li>
<li class="header__nav__list__item "><a href="/section/uae-50/">UAE 50</a></li>
<li class="header__nav__list__item "><a href="/cinema/">CINEMA</a></li>
<li class="header__nav__list__item "><a href="/section/culture/">CULTURE</a></li>
</ul>
</div>
<div class="header__nav-more__flex-row">

<div class="header__search">
<form role="search" method="get" action="https://whatson.ae" class="header__nav-more__search search__form__">
<input type="text" name="s" value="" placeholder="Search">
</form>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/search.svg" width="16" class="search__icon" alt="search icon">
</div>
<div class="header__login">
<a href="https://whatson.ae/knowledge/2990/newsletter-sign-up/">SIGN UP</a>
</div>
<div class="header__nav-dropdown">
<a class="more-btn-anchor"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/menu-button.svg" width="26" class="more-down-btn" alt="menu button icon"></a>
</div>
<ul class="header__nav-dropdown__sub-menu">
<li>
<a href="https://whatson.ae/section/nightlife/" class="hover-nav"><span>Nightlife</span></a>
</li>
<li>
<a href="https://whatson.ae/section/culture/" class="hover-nav hover__dropdown"><span>Culture</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/culture/film/" class="hover-nav"><span>Film</span></a></li>
<li><a href="https://whatson.ae/section/culture/theatre/" class="hover-nav"><span>Theatre</span></a></li>
<li><a href="https://whatson.ae/section/culture/art/" class="hover-nav"><span>Art</span></a></li>
<li><a href="https://whatson.ae/section/culture/technology/" class="hover-nav"><span>Tech</span></a></li>
<li><a href="https://whatson.ae/section/culture/workshops/" class="hover-nav"><span>Workshops</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/travel/" class="hover-nav hover__dropdown"><span>Travel</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/travel/travel-deals/" class="hover-nav"><span>Deals</span></a></li>
<li><a href="https://whatson.ae/section/travel/staycations/" class="hover-nav"><span>Staycations</span></a></li>
<li><a href="https://whatson.ae/section/travel/short-haul/" class="hover-nav"><span>Short Haul</span></a></li>
<li><a href="https://whatson.ae/section/travel/long-haul/" class="hover-nav"><span>Long Haul</span></a></li>
</ul>
</li>
<li>
 <a href="https://whatson.ae/section/active/" class="hover-nav hover__dropdown"><span>Sports & Fitness</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/active/workouts/" class="hover-nav"><span>Workouts</span></a></li>
<li><a href="https://whatson.ae/section/active/indoor/" class="hover-nav"><span>Indoor</span></a></li>
<li><a href="https://whatson.ae/section/active/outdoor/" class="hover-nav"><span>Outdoor</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/well-being/" class="hover-nav hover__dropdown"><span>Wellbeing</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/well-being/spas/" class="hover-nav"><span>Spas</span></a></li>
<li><a href="https://whatson.ae/section/well-being/beauty/" class="hover-nav"><span>Beauty</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/pets/" class="hover-nav"><span>Pets</span></a>
</li>
<li>
<a href="https://whatson.ae/section/shopping/" class="hover-nav"><span>Shopping</span></a>
</li>
<li>
<a href="https://whatson.ae/section/family/" class="hover-nav"><span>Family</span></a>
</li>
<li>
<a href="https://whatson.ae/section/competitions/" class="hover-nav"><span>Competitions</span></a>
</li>
<li><a href="https://whatson.ae/events/" class="hover-nav"><span>Events</span></a></li>
</ul>
</div>
</div>
</div>
</div>
<img src="https://pubads.g.doubleclick.net/activity;dc_iu=/21835097498/DFPAudiencePixel;ord=1;dc_seg=6575138653?" width=1 height=1 border=0/>
</header>

<div class="sticky__header">
<div class="sticky__header__inner max-width">
<div class="sticky__header__inner__flex_row">
<div class="header__logo-wrapper">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="250" alt="logo icon"></a>
</div>
<div class="header__bottom">
<div class="header__bottom__flex-row  max-width">
<div class="header__nav">
<ul class="header__nav__list">
<li class="header__nav__list__item "><a href="/section/news/">NEWS</a></li>
<li class="header__nav__list__item "><a href="/section/eat/">EAT &amp; DRINK</a></li>
<li class="header__nav__list__item "><a href="/section/things-to-do/">THINGS TO DO</a></li>
<li class="header__nav__list__item "><a href="/section/uae-50/">UAE 50</a></li>
<li class="header__nav__list__item "><a href="/cinema/">CINEMA</a></li>
<li class="header__nav__list__item "><a href="/section/culture/">CULTURE</a></li>
</ul>
 </div>
<div class="header__nav-more__flex-row">

<div class="header__search">
<form role="search" method="get" action="https://whatson.ae" class="header__nav-more__search search__form__">
<input type="text" name="s" value="" placeholder="Search">
</form>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/search.svg" width="16" class="search__icon" alt="search icon">
</div>
<div class="header__login">
<a href="http://local.whatson.ae/dubai/knowledge/2990/newsletter-sign-up/">SIGN UP</a>
</div>
<div class="header__nav-dropdown">
<a class="more-btn-anchor"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/menu-button.svg" width="26" class="more-down-btn" alt="menu icon"></a>
</div>
<ul class="header__nav-dropdown__sub-menu">
<li>
<a href="https://whatson.ae/section/nightlife/" class="hover-nav"><span>Nightlife</span></a>
</li>
<li>
<a href="https://whatson.ae/section/culture/" class="hover-nav hover__dropdown"><span>Culture</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/culture/film/" class="hover-nav"><span>Film</span></a></li>
<li><a href="https://whatson.ae/section/culture/theatre/" class="hover-nav"><span>Theatre</span></a></li>
<li><a href="https://whatson.ae/section/culture/art/" class="hover-nav"><span>Art</span></a></li>
<li><a href="https://whatson.ae/section/culture/technology/" class="hover-nav"><span>Tech</span></a></li>
<li><a href="https://whatson.ae/section/culture/workshops/" class="hover-nav"><span>Workshops</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/travel/" class="hover-nav hover__dropdown"><span>Travel</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/travel/travel-deals/" class="hover-nav"><span>Deals</span></a></li>
<li><a href="https://whatson.ae/section/travel/staycations/" class="hover-nav"><span>Staycations</span></a></li>
<li><a href="https://whatson.ae/section/travel/short-haul/" class="hover-nav"><span>Short Haul</span></a></li>
<li><a href="https://whatson.ae/section/travel/long-haul/" class="hover-nav"><span>Long Haul</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/active/" class="hover-nav hover__dropdown"><span>Sports & Fitness</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/active/workouts/" class="hover-nav"><span>Workouts</span></a></li>
<li><a href="https://whatson.ae/section/active/indoor/" class="hover-nav"><span>Indoor</span></a></li>
<li><a href="https://whatson.ae/section/active/outdoor/" class="hover-nav"><span>Outdoor</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/well-being/" class="hover-nav hover__dropdown"><span>Wellbeing</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/well-being/spas/" class="hover-nav"><span>Spas</span></a></li>
<li><a href="https://whatson.ae/section/well-being/beauty/" class="hover-nav"><span>Beauty</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/pets/" class="hover-nav"><span>Pets</span></a>
</li>
<li>
<a href="https://whatson.ae/section/shopping/" class="hover-nav"><span>Shopping</span></a>
</li>
<li>
<a href="https://whatson.ae/section/family/" class="hover-nav"><span>Family</span></a>
</li>
<li>
<a href="https://whatson.ae/section/competitions/" class="hover-nav"><span>Competitions</span></a>
</li>
<li><a href="https://whatson.ae/events/" class="hover-nav"><span>Events</span></a></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>

<header class="header-mobile">
<div class="header-mobile__inner">
<div class="header-mobile__flex-row">
<div class="header-mobile__signup">
<a href=""><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/female-icon.svg" width="18" alt="account icon"></a>
</div>
<div class="header-mobile__logo-wrapper">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="108" alt="logo icon"></a>
</div>
<div class="header-mobile__menu">
<a href="https://whatson.ae/knowledge/2990/newsletter-sign-up/" class="mobile__signup__btn">Sign up</a>
<div class="header-mobile__menu__inner">
<div class="header-mobile__menu__each"></div>
<div class="header-mobile__menu__each header-mobile__menu__each--wide"></div>
<div class="header-mobile__menu__each"></div>
</div>
</div>
</div>
<div class="header-mobile__menu__content">
<div class="header-mobile__menu__content__inner">
<div class="header-mobile__menu__content__inner">
<div class="header-mobile__menu__content__each ">
<a href="/section/news/">NEWS</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/eat/">EAT & DRINK</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/things-to-do/">THINGS TO DO</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/uae-50/">UAE 50</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/cinema/">CINEMA</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/culture/">CULTURE</a>
</div>
</div>
<div class="header-mobile__menu__search-more">
<div class="header-mobile__menu__search">
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/search.svg" width="16" class="search__icon" alt="search icon">
</div>
<form role="search" method="get" action="https://whatson.ae" class="header-mobile__menu__search__form search__form__">
<input type="text" name="s" value="" placeholder="Search" class="header-mobile__menu__search__textbox">
</form>
<div class="header-mobile__menu__more">
<a href="">MORE &nbsp;<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/down-arrow-white-new.svg" width="12" class="more-down-btn" alt="more button icon"></a>
</div>
</div>
<div>
<ul class="header-mobile__nav-dropdown__sub-menu">
<li>
<a href="https://whatson.ae/section/nightlife/" class="hover-nav"><span>Nightlife</span></a>
</li>
<li>
<a href="https://whatson.ae/section/culture/" class="hover-nav hover__dropdown"><span>Culture</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/culture/film/" class="hover-nav"><span>Film</span></a></li>
<li><a href="https://whatson.ae/section/culture/theatre/" class="hover-nav"><span>Theatre</span></a></li>
<li><a href="https://whatson.ae/section/culture/art/" class="hover-nav"><span>Art</span></a></li>
<li><a href="https://whatson.ae/section/culture/technology/" class="hover-nav"><span>Tech</span></a></li>
<li><a href="https://whatson.ae/section/culture/workshops/" class="hover-nav"><span>Workshops</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/travel/" class="hover-nav hover__dropdown"><span>Travel</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/travel/travel-deals/" class="hover-nav"><span>Deals</span></a></li>
<li><a href="https://whatson.ae/section/travel/staycations/" class="hover-nav"><span>Staycations</span></a></li>
<li><a href="https://whatson.ae/section/travel/short-haul/" class="hover-nav"><span>Short Haul</span></a></li>
<li><a href="https://whatson.ae/section/travel/long-haul/" class="hover-nav"><span>Long Haul</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/active/" class="hover-nav hover__dropdown"><span>Sports & Fitness</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/active/workouts/" class="hover-nav"><span>Workouts</span></a></li>
<li><a href="https://whatson.ae/section/active/indoor/" class="hover-nav"><span>Indoor</span></a></li>
<li><a href="https://whatson.ae/section/active/outdoor/" class="hover-nav"><span>Outdoor</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/well-being/" class="hover-nav hover__dropdown"><span>Wellbeing</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/well-being/spas/" class="hover-nav"><span>Spas</span></a></li>
<li><a href="https://whatson.ae/section/well-being/beauty/" class="hover-nav"><span>Beauty</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/pets/" class="hover-nav"><span>Pets</span></a>
</li>
<li>
<a href="https://whatson.ae/section/shopping/" class="hover-nav"><span>Shopping</span></a>
</li>
<li>
<a href="https://whatson.ae/section/family/" class="hover-nav"><span>Family</span></a>
</li>
<li>
<a href="https://whatson.ae/section/competitions/" class="hover-nav"><span>Competitions</span></a>
</li>
<li><a href="https://whatson.ae/events/" class="hover-nav"><span>Events</span></a></li>
</ul>
</div>
<div class="header-mobile___signup">
<div class="header-mobile___signup__btn">
SIGN UP & CUSTOMISE
</div>
</div>
</div>
</div>
</div>
</header>
<div class="article-content max-width">
<div style="position:absolute;left:-170px; width: 160px;height: 600px;" class="show__desktop">

<div id='div-gpt-ad-1601453825783-0' style='width: 160px; height: 600px;'>
<script>
                                    googletag.cmd.push(function() {  
                                        googletag.display('div-gpt-ad-1601453825783-0');                           
                                     });
                                  </script>
</div>
</div>
<div style="position:absolute; right:-170px; width: 160px;height: 600px;" class="show__desktop">

<div id='div-gpt-ad-1601453825783-1' style='width: 160px; height: 600px;'>
<script>
                                    googletag.cmd.push(function() {  
                                        googletag.display('div-gpt-ad-1601453825783-1');                             
                                     });
                                  </script>
</div>
</div>
<div class="article-content__inner">
<div class="article-content__flex-row">
<div class="article-content__left">

<div class="article-content__left__top">
<div class="article-content__image lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-feat.jpg)">
</div>

<h1 class="article-content__title">
<span class="outerSpan">
<span class="innerSpan">
5 new and returning brunches to try in Dubai this weekend </span>
</span>
</h1>
</div>
<div class="article-content__meta">

<div class="article-content__social">
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="fb" data-link="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" data-picture="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-feat.jpg" data-name="5 new and returning brunches to try in Dubai this weekend" data-caption="5 new and returning brunches to try in Dubai this weekend" data-description="Is it the weekend yet? If you&#8217;re looking for somewhere to brunch this weekend, we&#8217;ve got you covered with some brand new brunches and some old returning favorites. From family-friendly&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/facebook.svg" width="38" alt="facebook follow"></a>
</div>
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="tw" data-link="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" data-picture="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-feat.jpg" data-name="5 new and returning brunches to try in Dubai this weekend" data-caption="5 new and returning brunches to try in Dubai this weekend" data-description="Is it the weekend yet? If you&#8217;re looking for somewhere to brunch this weekend, we&#8217;ve got you covered with some brand new brunches and some old returning favorites. From family-friendly&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/twitter.svg" width="38" alt="twitter follow"></a>
</div>
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="whatsapp" data-link="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" data-picture="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-feat.jpg" data-name="5 new and returning brunches to try in Dubai this weekend" data-caption="5 new and returning brunches to try in Dubai this weekend" data-description="Is it the weekend yet? If you&#8217;re looking for somewhere to brunch this weekend, we&#8217;ve got you covered with some brand new brunches and some old returning favorites. From family-friendly&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/whatsapp.svg" width="38" alt="whatsapp follow"></a>
</div>
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="mail" data-link="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" data-picture="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-feat.jpg" data-name="5 new and returning brunches to try in Dubai this weekend" data-caption="5 new and returning brunches to try in Dubai this weekend" data-description="Is it the weekend yet? If you&#8217;re looking for somewhere to brunch this weekend, we&#8217;ve got you covered with some brand new brunches and some old returning favorites. From family-friendly&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/mail.svg" width="38" alt="mail follow"></a>
</div>
</div>

<div class="article-content__tags article-content__tags--top">
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/eat/brunch/">
Brunch </a>
</div>
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/eat/">
Eat & Drink </a>
</div>
</div>

<div class="article-content__author">
<div class="article-content__author__image">
<img alt='Lauren Fletcher' src='https://whatson.ae/dubai/wp-content/uploads/2019/04/Lauren-Fletcher_avatar_1555833711.jpg' class='avatar avatar-45 photo' height='45' width='45' /> </div>
<div class="article-content__author__detail">
Written by: <br><strong> Lauren Fletcher </strong><br>
9 hours ago </div>
</div>
</div>

<div class="article-content__description">
<div class="article-text"><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"><h4>Is it the weekend yet?</h4><p>If you&rsquo;re looking for somewhere to brunch this weekend, we&rsquo;ve got you covered with some brand new brunches and some old returning favorites. From family-friendly brunches to a night brunch or pool party brunch, there&rsquo;s something for everyone.</p><p><strong>Cheers to the weekend&hellip;&nbsp;</strong></p><h1>Thursday</h1><h3>Paros</h3><div class="gallery__empty"></div><p><img class="alignnone size-full wp-image-170267" src="https://whatson.ae/wp-content/uploads/2020/08/paros-article.jpg" alt="" width="800" height="533"></p><p><strong>Best for: Night owls</strong></p><p>Cool rooftop bar Paros, which can be found 46 floors high at Taj Jumeirah Lakes Towers, <a href="https://whatson.ae/2021/09/a-new-thursday-night-brunch-launches-at-this-cool-rooftop-bar/" target="_blank" rel="noopener noreferrer">just launched the new &lsquo;Nisi Night Brunch&rsquo;</a> that runs every Thursday evening from 7pm to 10.30pm. Guests to the night brunch can enjoy free-flowing beverages, unlimited starters, a main course and a dessert. There will be no shortage of entertainment on the night, with an electric percussionist, as well as two DJs.</p><p><em>Paros, Taj Jumeirah Lakes Towers, Dubai, Thursdays, 7pm to 10.30pm, priced from Dhs225. Tel:&nbsp;(<span role="link" aria-label="Call phone number 04 574 1111">04) 574 1111. <a href="https://www.tajhotels.com/en-in/taj/taj-jumeirah-lakes-towers/restaurants/paros/" target="_blank" rel="noopener noreferrer">tajhotels.com</a></span></em></p><h1>Friday</h1><h3>Crescendo</h3><div class="empty-ad removeFloat"></div><p><img class="alignnone size-full wp-image-209192" src="https://whatson.ae/wp-content/uploads/2021/09/brunch-anantara-palm-article.jpg" alt="" width="800" height="533"></p><p><strong>Best for: Friends and families</strong></p><p>The <a href="https://whatson.ae/2021/09/why-this-palm-jumeirah-brunch-is-a-must-visit/" target="_blank" rel="noopener noreferrer">&lsquo;Fork and Cork&rsquo; brunch is back</a> and&nbsp;the restaurant it takes place in, Crescendo&nbsp;at Anantara The Palm, has had a complete makeover, and it&rsquo;s better than ever. The brunch relaunches on Friday, September 17 and will run every Friday thereafter from 1pm to 4pm, with packages priced from Dhs365. You can bag a table in the fresh new dining room or, when the cooler weather rolls in, sit outside on the terrace and dine alfresco by the pool. For those who love to try a bit of everything, there&rsquo;s live stations offering up pizza, pasta, salads, meat and plenty of different international cuisines.</p><p><em>Fork and Cork, Crescendo, Anantara The Palm, Palm Jumeirah, Dubai, Dhs365 for soft drinks, Dhs525 for house drinks, Dhs630 for house with prosecco and Dhs735 for the champagne package . Tel: (0) 4 567 8304.&nbsp;<a href="https://www.anantara.com/en/palm-dubai?utm_source=GoogleMyBusiness&amp;utm_medium=GMB&amp;utm_term=DubaiThePalm&amp;utm_content=Home&amp;utm_campaign=Google_GMB" target="_blank" rel="noopener noreferrer">anantara.com</a></em></p><h3>Larte</h3><p><img class="alignnone size-full wp-image-187892" src="https://whatson.ae/wp-content/uploads/2021/01/larte-business-lunch.jpg" alt="larte business lunch" width="800" height="534"></p><p><strong>Best for: Families (and keeping the little ones entertained)</strong></p><p>The little ones are back at school now so you&rsquo;ll be wanting to spend that quality time with them on a weekend. Fun Italian restaurant Larte is launching a family festival brunch on Friday, September 17. There&rsquo;s free-flowing drinks, pizza and pasta stations, as well as boardgames, a games room, a cinema, mime artist and more to keep the little ones entertained.</p><p><em>Larte, Studio One Hotel, Dubai Studio City, Dubai, Fridays, 1pm to 4pm, Dhs175 soft drinks, Dhs299 house drinks, Dhs75 kids under 12, Dhs699 family ticket including two adults and two children. Tel: (0)4 581 6800. <a href="https://www.instagram.com/larte.dubai/" target="_blank" rel="noopener noreferrer">@larte.dubai</a></em></p><h3>Reform Social &amp; Grill</h3><p><img class="alignnone size-full wp-image-195455" src="https://whatson.ae/wp-content/uploads/2021/03/pjimage-1-13.jpg" alt="reform social and grill" width="800" height="533"></p><p><strong>Best for: A relaxed family-friendly scene</strong></p><p>Check out Reform Social Bar &amp; Grill&rsquo;s <a href="https://whatson.ae/2021/09/reform-launches-friday-family-brunch-with-live-music-games-and-more/" target="_blank" rel="noopener noreferrer">brand new &lsquo;Family Friday Brunch&rsquo;</a>. It will take place inside the venue&rsquo;s &lsquo;summer garden&rsquo; tent, which is fully air-conditioned to beat the heat. Once the weather has cooled down, it will move outside into Reform&rsquo;s popular lakeside garden. You&rsquo;ll enjoy a three-course menu of British pub classics and free-flowing beverages (including fizz). There will be live music by Oli and Kane, also known as The Kick&nbsp;and&nbsp;children will be kept entertained all day so the adults can have some grown up time.</p><div class="article-content__you-may-like">
<h3>You might also like</h3>
<div class="article-content__you-may-like__each">
<a href="https://whatson.ae/2021/09/splash-around-with-these-summer-deals-at-waterparks-in-the-uae/" target="_blank">
Splash around and save on tickets to the best waterparks in Dubai </a>
</div>
</div><p><em>Reform Social Bar &amp; Grill, The Lakes, Dubai, Fridays from September 10, 1pm to 4pm, Dhs350 for house beverages, Dhs199 for soft beverages and Dhs99 for kids (under 5&rsquo;s are free). Tel: (0)4 454 2638. <a href="https://www.instagram.com/reformdubai/" target="_blank" rel="noopener noreferrer">@reformdubai</a></em></p><h1>Friday and Saturday</h1><h3>Zero Gravity</h3><p><img class="alignnone size-full wp-image-209256" src="https://whatson.ae/wp-content/uploads/2021/09/zero-gravity-article.jpg" alt="Zero Gravity" width="800" height="533"></p><p><strong>Best for: Sun seekers</strong></p><p>Zero Gravity&rsquo;s two most popular poolside brunches are back and bigger than ever. On Fridays the Tropical Brunch &ndash; with those famous bottomless pineapple cups &ndash; will be in full swing. And on Saturdays, the award-winning Supernatural brunch is back Friday&rsquo;s Tropical Brunch runs from 1pm to 5pm, priced at Dhs299 for ladies and Dhs349 guys, inclusive of unlimited food and house beverages. The food and cocktail stations are back outside and DJs will be playing all day.</p><p><em>Zero Gravity, Dubai Marina, Dubai, open 10 am to 9pm daily. Tel: (0)4 399 0009. <a href="https://www.0-gravity.ae" target="_blank" rel="noopener noreferrer">0-gravity.ae</a></em></p><p><em>Images: Social/Provided</em></p></div><p></p>

<div class="article-content__sign-up">
<div class="article-content__sign-up__btn hover-opacity">
<a href="https://whatson.ae/knowledge/2990/newsletter-sign-up/">
Sign up!
</a>
</div>
<div class="article-content__sign-up__text">
> Sign up for FREE to get exclusive updates that you are interested in
</div>
</div>

<div class="article-content__footer-meta">
<div class="article-content__footer-meta__social">
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="fb" data-link="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" data-picture="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-feat.jpg" data-name="5 new and returning brunches to try in Dubai this weekend" data-caption="5 new and returning brunches to try in Dubai this weekend" data-description="Is it the weekend yet? If you&#8217;re looking for somewhere to brunch this weekend, we&#8217;ve got you covered with some brand new brunches and some old returning favorites. From family-friendly&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/facebook.svg" width="38" alt="facebook follow"></a>
</div>
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="tw" data-link="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" data-picture="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-feat.jpg" data-name="5 new and returning brunches to try in Dubai this weekend" data-caption="5 new and returning brunches to try in Dubai this weekend" data-description="Is it the weekend yet? If you&#8217;re looking for somewhere to brunch this weekend, we&#8217;ve got you covered with some brand new brunches and some old returning favorites. From family-friendly&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/twitter.svg" width="38" alt="twitter follow"></a>
</div>
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="whatsapp" data-link="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" data-picture="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-feat.jpg" data-name="5 new and returning brunches to try in Dubai this weekend" data-caption="5 new and returning brunches to try in Dubai this weekend" data-description="Is it the weekend yet? If you&#8217;re looking for somewhere to brunch this weekend, we&#8217;ve got you covered with some brand new brunches and some old returning favorites. From family-friendly&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/whatsapp.svg" width="38" alt="whatsapp follow"></a>
</div>
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="mail" data-link="https://whatson.ae/2021/09/5-new-and-returning-brunches-to-try-in-dubai-this-weekend/" data-picture="https://whatson.ae/wp-content/uploads/2021/09/5-new-brunches-dubai-feat.jpg" data-name="5 new and returning brunches to try in Dubai this weekend" data-caption="5 new and returning brunches to try in Dubai this weekend" data-description="Is it the weekend yet? If you&#8217;re looking for somewhere to brunch this weekend, we&#8217;ve got you covered with some brand new brunches and some old returning favorites. From family-friendly&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/mail.svg" width="38" alt="mail follow"></a>
</div>
</div>

<div class="article-content__footer-meta__tags">
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/eat/brunch/" style="color:white; font-weight: 400;">
Brunch </a>
</div>
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/eat/" style="color:white; font-weight: 400;">
Eat & Drink </a>
</div>
</div>
</div>
</div>
</div>

<div class="article-content__right">

<div class="article-content--top-right-parent">
<div class="ad-wrapper article-content--top-right">
<div class="ad-wrapper__inner add__with__bg">
<div class="ad-wrapper__300x250">

<div class="">

<div id='div-gpt-ad-1594287406506-0'>
<script>
                                                googletag.cmd.push(function() { 
                                                    googletag.display('div-gpt-ad-1594287406506-0'); 
                                                });
                                            </script>
</div>
</div>
</div>
</div>
</div>
</div>

<div class="special-articles special-articles--right-side editors-pick__styl2">
<div class="article-content__title-without-bg">
<div class="article-content__title-without-bg__text">EDITOR’S PICKS</div>
</div>
<div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/09/whats-on-nightlife-awards-2021-here-are-the-nominees/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/08/whats-on-nightlife-2021-ft.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/09/whats-on-nightlife-awards-2021-here-are-the-nominees/">
<span class="outerSpan">
<span class="innerSpan">
What’s On Nightlife Awards 2021: Here are the nominees...
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/09/whats-on-nightlife-awards-2021-here-are-the-nominees/">READ MORE</a>
</div>
</div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/08/its-back-whats-on-lock-in-returns-to-media-one-hotel/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/08/featured-1.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/08/its-back-whats-on-lock-in-returns-to-media-one-hotel/">
<span class="outerSpan">
<span class="innerSpan">
It's back! What's On Lock In returns to Media One Hotel
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/08/its-back-whats-on-lock-in-returns-to-media-one-hotel/">READ MORE</a>
</div>
</div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/09/arts-and-culture-spots-we-cant-wait-to-visit-at-expo-2020-dubai/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/09/featured.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/09/arts-and-culture-spots-we-cant-wait-to-visit-at-expo-2020-dubai/">
<span class="outerSpan">
<span class="innerSpan">
Arts and culture: 5 spots we can't wait to visit at Expo 2020 Dubai
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/09/arts-and-culture-spots-we-cant-wait-to-visit-at-expo-2020-dubai/">READ MORE</a>
</div>
</div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/08/uae-petrol-prices-september-2021/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2020/03/petrol-featured-new.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/08/uae-petrol-prices-september-2021/">
<span class="outerSpan">
<span class="innerSpan">
UAE petrol prices are set to decrease in September 2021
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/08/uae-petrol-prices-september-2021/">READ MORE</a>
</div>
</div>
</div>
</div>

<div class="ad-wrapper">
<div class="ad-wrapper__inner add__with__bg">
<div class="ad-wrapper__300x600">

<div class="">
<div id='div-gpt-ad-1564911910443-0'>
<script>
                                            googletag.cmd.push(function() { 
                                                googletag.display('div-gpt-ad-1564911910443-0'); 
                                            });
                                        </script>
</div>
</div>
</div>
</div>
</div>

<div class="special-articles--right-side">
<div class="special-articles">
<div class="special-articles__title">
<span>MOST POPULAR</span>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/09/pics-of-the-week-your-best-photos-of-the-uae-87/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/09/featured-3.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/09/pics-of-the-week-your-best-photos-of-the-uae-87/">
Pics of the week: Your best photos of the UAE </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/09/how-to-us-playkey-me-the-regions-first-supercharged-cloud-gaming-service/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/09/Playkey-Server-Background3-copy-2.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/09/how-to-us-playkey-me-the-regions-first-supercharged-cloud-gaming-service/">
How to use Playkey.me, the region's first supercharged cloud gaming service </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/09/the-mai-dubai-half-marathon-is-back-in-october/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/09/MaiDubai-feat.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/09/the-mai-dubai-half-marathon-is-back-in-october/">
The Mai Dubai half marathon is back in October </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/09/exhibitions-workshops-and-more-to-experience-at-sharjah-art-foundation/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/09/pjimage-5.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/09/exhibitions-workshops-and-more-to-experience-at-sharjah-art-foundation/">
Exhibitions, workshops and more to experience at Sharjah Art Foundation  </a>
</div>
</div>
</div>
<div class="special-articles__each">
 <div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/09/new-irish-pub-mccaffertys-opens-second-venue-in-dubai/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/09/mccaffertys-dubai-furjan-featured.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/09/new-irish-pub-mccaffertys-opens-second-venue-in-dubai/">
New Irish pub McCafferty's opens second venue in Dubai </a>
</div>
</div>
</div>
</div>
</div>

<div class="checkArticleHalfpage"></div>
<div class="ad-wrapper second__MPU hp_floatAd">
<div class="ad-wrapper__inner add__with__bg">
<div class="ad-wrapper__300x250">

<div class="">
<div id='div-gpt-ad-1564911876216-0'>
<script>
                                            googletag.cmd.push(function() { 
                                                googletag.display('div-gpt-ad-1564911876216-0'); 
                                            });
                                        </script>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<div class="article-content__title-without-bg you__should__also">
<div class="article-content__title-without-bg__text">YOU SHOULD CHECK OUT</div>
</div>
<div class="load__home__content" data-category="eat">
</div>
</div> 
</div> 
<footer>
</footer>
</div> 
</div> 
<footer class="footer__wrapper">
<div class="footer__wrapper__inner max-width">
<div class="footer__menu">
<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-824" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-824"><a href="https://whatson.ae/about/advertising/">Advertise with us</a></li>
<li id="menu-item-825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-825"><a href="https://whatson.ae/about/legal/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-827" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-827"><a href="https://whatson.ae/about/">About Motivate</a></li>
</ul></div> </div>
<div class="footer__copyright">
<p class="">Motivate Media Group © 2021</p>
</div>
</div>
</footer>
<div id='fb-pxl-ajax-code'></div>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/ab2d0.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctcc_vars = {"expiry":"30","method":"1","version":"1"};
/* ]]> */
</script>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/60ad6.js"></script>
<script type="text/javascript">
					jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
																	});
				</script>
<div id="catapult-cookie-bar" class=""><div class="ctcc-inner "><span class="ctcc-left-side">Our website uses cookies and other similar technologies to improve our site and your online experience. By continuing to use our website you consent to cookies being used. <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://whatson.ae/about/legal/privacy-policy/">Read our privacy policy here.</a></span><span class="ctcc-right-side"><button id="catapultCookie" tabindex=0 onclick="catapultAcceptCookies();">Okay, thanks</button></span></div></div>
<script type="text/javascript">
    adroll_adv_id = "J636N26HTRH3HF2B3FJ6YO";
    adroll_pix_id = "RKAQBLXCRBAWDEYT7X6FNW";
    (function () {
        var oldonload = window.onload;
        window.onload = function(){
            __adroll_loaded=true;
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
             document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
            if(oldonload){oldonload()}};
    }());
</script>
<script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
<script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>
<script src="https://tags.crwdcntrl.net/c/8987/cc_af.js"></script>
<img src="//qa-gmtdmp.mookie1.com/t/v2/learn?tagid=V2_10308&src.rand=[timestamp]&src.id=[optionally replace with unique identifier]" style="display:none;" />
<script type="text/javascript">
    adroll_adv_id = "J636N26HTRH3HF2B3FJ6YO";
    adroll_pix_id = "RKAQBLXCRBAWDEYT7X6FNW";
    (function () {
    var oldonload = window.onload;
    window.onload = function(){
       __adroll_loaded=true;
       var scr = document.createElement("script");
       var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
       scr.setAttribute('async', 'true');
       scr.type = "text/javascript";
       scr.src = host + "/j/roundtrip.js";
       ((document.getElementsByTagName('head') || [null])[0] ||
        document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
       if(oldonload){oldonload()}};
    }());
</script>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/7a133.js"></script>
<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/106581/tag"></script>
<script type="text/javascript">
    $(window).load(function()
    {
        masonryContent();
    });
</script>
</body></html>
