<!DOCTYPE html>
<html lang="en-GB">
<head><link rel="stylesheet" type="text/css" href="https://whatson.ae/wp-content/cache/minify/491f1.css" media="all" />
<meta charset="UTF-8">
<title>American megastar Flo Rida to perform in Dubai this week - What&#039;s On</title>
<meta name="keywords" content="" />

<meta name="viewport" content="width=device-width, user-scalable=no" />

<meta name="description" content="It&#039;s going down for real...Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week." />
<link rel="original-source" href="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="American megastar Flo Rida to perform in Dubai this week" />
<meta property="og:description" content="It&#039;s going down for real..." />
<meta property="og:url" content="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" />
<meta property="og:site_name" content="What&#039;s On" />
<meta property="article:publisher" content="https://www.facebook.com/WhatsOnDubai" />
<meta property="article:tag" content="clubbing" />
<meta property="article:tag" content="events" />
<meta property="article:tag" content="flo rida" />
<meta property="article:tag" content="nightlife" />
<meta property="article:section" content="Nightlife" />
<meta property="article:published_time" content="2021-08-08T09:15:34+00:00" />
<meta property="article:modified_time" content="2021-08-08T09:40:12+00:00" />
<meta property="og:updated_time" content="2021-08-08T09:40:12+00:00" />
<meta property="fb:app_id" content="521837017887988" />
<meta property="og:image" content="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-fb.jpg" />
<meta property="og:image:secure_url" content="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-fb.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="It&#039;s going down for real...Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week." />
<meta name="twitter:title" content="American megastar Flo Rida to perform in Dubai this week - What&#039;s On" />
<meta name="twitter:site" content="@WhatsOnDubai" />
<meta name="twitter:image" content="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-fb.jpg" />
<meta name="twitter:creator" content="@WhatsOnDubai" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://whatson.ae/#website","url":"https://whatson.ae/","name":"What&#039;s On","description":"Things to do in Dubai &amp; the UAE","potentialAction":{"@type":"SearchAction","target":"https://whatson.ae/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/#primaryimage","url":"https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg","width":800,"height":440},{"@type":"WebPage","@id":"https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/#webpage","url":"https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/","inLanguage":"en-GB","name":"American megastar Flo Rida to perform in Dubai this week - What&#039;s On","isPartOf":{"@id":"https://whatson.ae/#website"},"primaryImageOfPage":{"@id":"https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/#primaryimage"},"datePublished":"2021-08-08T09:15:34+00:00","dateModified":"2021-08-08T09:40:12+00:00","author":{"@id":"https://whatson.ae/#/schema/person/bdc2815e3f90869e0b407d1d7541c4bf"},"description":"It's going down for real...Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week."},{"@type":["Person"],"@id":"https://whatson.ae/#/schema/person/bdc2815e3f90869e0b407d1d7541c4bf","name":"Elise Kerr","image":{"@type":"ImageObject","@id":"https://whatson.ae/#authorlogo","url":"https://secure.gravatar.com/avatar/1a709e2265e42bc6e5f0d0b627ae1399?s=96&d=mm&r=g","caption":"Elise Kerr"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="What&#039;s On &raquo; American megastar Flo Rida to perform in Dubai this week Comments Feed" href="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/whatson.ae\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/df983.js"></script>
<link rel='https://api.w.org/' href='https://whatson.ae/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://whatson.ae/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://whatson.ae/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.8" />
<link rel='shortlink' href='https://whatson.ae/?p=206650' />
<link rel="alternate" type="application/json+oembed" href="https://whatson.ae/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhatson.ae%2F2021%2F08%2Famerican-megastar-flo-rida-to-perform-in-dubai-this-week%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://whatson.ae/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhatson.ae%2F2021%2F08%2Famerican-megastar-flo-rida-to-perform-in-dubai-this-week%2F&#038;format=xml" />
<meta property="fb:pages" content="133671683313479" />
<meta property="ia:markup_url" content="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/?ia_markup=1" />
<style id="ctcc-css" type="text/css" media="screen">
				#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ddd;
					position: fixed;
					left: 0;
					bottom: 0;
					width: 100%;
					background-color: #000000;
				}
				#catapult-cookie-bar a {
					color: #fff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: #000000;
				}
				button#catapultCookie {
					background:#ffffff;
					color: #000000;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ddd;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style>

<meta name="wp-parsely_version" id="wp-parsely_version" content="2.0" />
<script type="application/ld+json">
		{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/whatson.ae\/2021\/08\/american-megastar-flo-rida-to-perform-in-dubai-this-week\/"},"headline":"American megastar Flo Rida to perform in Dubai this week","url":"https:\/\/whatson.ae\/2021\/08\/american-megastar-flo-rida-to-perform-in-dubai-this-week\/","thumbnailUrl":"https:\/\/whatson.ae\/wp-content\/uploads\/2021\/08\/flo-rida-dubai-ft.jpg","image":{"@type":"ImageObject","url":"https:\/\/whatson.ae\/wp-content\/uploads\/2021\/08\/flo-rida-dubai-ft.jpg"},"dateCreated":"2021-08-08T09:15:34Z","datePublished":"2021-08-08T09:15:34Z","dateModified":"2021-08-08T09:15:34Z","articleSection":"Clubs","author":[{"@type":"Person","name":"Elise Kerr"}],"creator":["Elise Kerr"],"keywords":["clubbing","events","flo rida","nightlife"],"publisher":{"@type":"Organization","name":"What&#039;s On","logo":{"@type":"ImageObject","url":""}}}
		</script>


<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>

<script type='text/javascript'>
  fbq('init', '301969470674972', {}, {
    "agent": "wordpress-5.3.8-3.0.0"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>

<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=301969470674972&ev=PageView&noscript=1" />
</noscript>

<style>.twentytwenty-container { margin-bottom: 5px ; background-color:#666666;}
    .smallcaption { font-size: 11px; color: #666666; margin-bottom: 15px;}
    .instagram-media { width:100%; }
    </style>
<link rel="stylesheet" href="https://whatson.ae/wp-content/themes/whatson-grow/js/royalslider/skins/default/rs-default.css">
<script src="https://whatson.ae/wp-content/themes/whatson-grow/js/royalslider/jquery.royalslider.min.js"></script>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/ae1ea.js"></script>
<style>.royalSlider {
      width: 100%;
      height: 412px;
    }</style>

<script type="text/javascript">
		window.bk_async = function() {
		 // ALLOW MULTIPLE CALLS/SINGLE PAGE APPS
		bk_allow_multiple_calls=true; bk_use_multiple_iframes=true ;
		 // <optional> PHINTS : Declare variables about this page (or user)
		bk_addPageCtx('page_type', 'Article'); // example phint (change to your own useful variabes)
		bk_addPageCtx('section', 'Clubs,Nightlife'); // example phint (change to your own useful variabes)
		bk_addPageCtx('article_ID', '206650'); // article_ID
		bk_addPageCtx("article_name", "American megastar Flo Rida to perform in Dubai this week"); // headline of article
		bk_addPageCtx("city", "Dubai"); // City		
		bk_addPageCtx("tag", "clubbing, events, flo rida, nightlife, "); // Tags		 
		 
		  // Send Data
		BKTAG.doTag(43849, 4);  // change "ENTER CONTAINER ID HERE" to the container ID/Site ID you want to use
		};
		(function() {
		  var scripts = document.getElementsByTagName('script')[0];
		  var s = document.createElement('script');
		  s.async = true;
		  s.src = "//tags.bkrtx.com/js/bk-coretag.js";
		  scripts.parentNode.insertBefore(s, scripts);
		}());
	</script>

<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/ff6a4.js"></script>

<script type="text/javascript">
	var _elqQ = _elqQ || [];
	_elqQ.push(['elqSetSiteId', '1244214268']);
	_elqQ.push(['elqTrackPageView']);

	(function () {
	    function async_load() {
	        var s = document.createElement('script'); s.type = 'text/javascript'; s.async = true;
	        s.src = '//img04.en25.com/i/elqCfg.min.js';
	        var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
	    }
	    if (window.addEventListener) window.addEventListener('DOMContentLoaded', async_load, false);
	    else if (window.attachEvent) window.attachEvent('onload', async_load);
	})();
</script>

<script id="parsely-cfg" data-parsely-site="whatson.ae" src="//cdn.parsely.com/keys/whatson.ae/p.js"></script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-13044993-17"></script>
<script>
        window.dataLayer = window.dataLayer || [];
        function gtag(){dataLayer.push(arguments);}
        gtag('js', new Date());

        gtag('config', 'UA-13044993-17');
    </script>
<link href="https://fonts.googleapis.com/css?family=Lato:400,700" rel="stylesheet">
<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') +
                    '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
            })();
        </script>
<script type='text/javascript'>
    var skinAd;
    var lbAd;
    var mobLbAd;
    var catfishAd;
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {

googletag.defineSlot('/21835097498/WhatsOn_NightLife_LBBB', [[728, 90], [970, 250]], 'div-gpt-ad-1564916030337-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_NightLife_MPU-ATF', [300, 250], 'div-gpt-ad-1594276737606-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_NightLife_MPU', [300, 250], 'div-gpt-ad-1564916076259-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_NightLife_HP', [300, 600], 'div-gpt-ad-1564916122119-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_Nightlife_Skyscraper', [160, 600], 'div-gpt-ad-1584618353125-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_Nightlife_Skyscraper', [160, 600], 'div-gpt-ad-1584618353125-1').addService(googletag.pubads());
googletag.pubads().setTargeting('Interests', ['Clubs' , 'Nightlife' ]);    googletag.pubads().disableInitialLoad();
    googletag.pubads().enableSingleRequest(); 
    googletag.pubads().collapseEmptyDivs(); 
    googletag.enableServices();
    googletag.pubads().refresh();

    googletag.pubads().addEventListener('slotRenderEnded', function(event) {
        console.log('Creative with id: ' + event.creativeId +
        ' is rendered to slot of size: ' + event.size[0] + 'x' + event.size[1]);

        if(event.size[0] == 728 ){
            $('.header__ad-leader-board').css('height', event.size[1]);
        }

        if(event.size[0] == 970 ){
            $('.header__ad-leader-board').css('height', event.size[1]);
            $('.header').addClass('billboardAd');
        }

    });
    
});
</script>
<style type="text/css">
    .twentytwenty-container img { margin: 0 0; }
    .follow-us__each { margin: 3px; }
</style>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-206650 single-format-standard">
<script type="text/javascript">
        var ajaxUrl = 'https://whatson.ae/wp-admin/admin-ajax.php';
        var baseUrl = 'https://whatson.ae';
        var tempUrl = 'https://whatson.ae/wp-content/themes/whatson-grow';
    </script>
<div class="wo__container">
<div class="wrapper" id="wrapper">

<header class="header header--desktop">
<div class="header--desktop__inner">
<div class="header__top">
<div class="header__top__flex-row  max-width">
<div class="header__logo__flex-row">
<div class="header__logo-wrapper">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="250" alt="logo icon"></a>
</div>
<div class="header__ad-leader-board">
<div class="header_ad-728x90">

<div id='div-gpt-ad-1564916030337-0'>
<script>
                                            googletag.cmd.push(function() {
                                                googletag.display('div-gpt-ad-1564916030337-0'); 
                                            });
                                        </script>
</div>
</div>
</div>
</div>
<div class="header__signup">
<a href="">Signup & Customize</a>
</div>
</div>
</div>
<div class="header__bottom">
<div class="header__bottom__flex-row  max-width">
<div class="header__nav">
<ul class="header__nav__list">
<li class="logo__inline">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="100" alt="logo icon"></a>
</li>
<li class="header__nav__list__item "><a href="/section/news/">NEWS</a></li>
<li class="header__nav__list__item "><a href="/section/eat/">EAT & DRINK</a></li>
<li class="header__nav__list__item "><a href="/section/things-to-do/">THINGS TO DO</a></li>
<li class="header__nav__list__item "><a href="/section/uae-50/">UAE 50</a></li>
<li class="header__nav__list__item "><a href="/cinema/">CINEMA</a></li>
<li class="header__nav__list__item "><a href="/section/culture/">CULTURE</a></li>
</ul>
</div>
<div class="header__nav-more__flex-row">

<div class="header__search">
<form role="search" method="get" action="https://whatson.ae" class="header__nav-more__search search__form__">
<input type="text" name="s" value="" placeholder="Search">
</form>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/search.svg" width="16" class="search__icon" alt="search icon">
</div>
<div class="header__login">
<a href="https://whatson.ae/knowledge/2990/newsletter-sign-up/">SIGN UP</a>
</div>
<div class="header__nav-dropdown">
<a class="more-btn-anchor"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/menu-button.svg" width="26" class="more-down-btn" alt="menu button icon"></a>
</div>
<ul class="header__nav-dropdown__sub-menu">
<li>
<a href="https://whatson.ae/section/nightlife/" class="hover-nav"><span>Nightlife</span></a>
</li>
<li>
<a href="https://whatson.ae/section/culture/" class="hover-nav hover__dropdown"><span>Culture</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/culture/film/" class="hover-nav"><span>Film</span></a></li>
<li><a href="https://whatson.ae/section/culture/theatre/" class="hover-nav"><span>Theatre</span></a></li>
<li><a href="https://whatson.ae/section/culture/art/" class="hover-nav"><span>Art</span></a></li>
<li><a href="https://whatson.ae/section/culture/technology/" class="hover-nav"><span>Tech</span></a></li>
<li><a href="https://whatson.ae/section/culture/workshops/" class="hover-nav"><span>Workshops</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/travel/" class="hover-nav hover__dropdown"><span>Travel</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/travel/travel-deals/" class="hover-nav"><span>Deals</span></a></li>
<li><a href="https://whatson.ae/section/travel/staycations/" class="hover-nav"><span>Staycations</span></a></li>
<li><a href="https://whatson.ae/section/travel/short-haul/" class="hover-nav"><span>Short Haul</span></a></li>
<li><a href="https://whatson.ae/section/travel/long-haul/" class="hover-nav"><span>Long Haul</span></a></li>
</ul>
</li>
<li>
 <a href="https://whatson.ae/section/active/" class="hover-nav hover__dropdown"><span>Sports & Fitness</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/active/workouts/" class="hover-nav"><span>Workouts</span></a></li>
<li><a href="https://whatson.ae/section/active/indoor/" class="hover-nav"><span>Indoor</span></a></li>
<li><a href="https://whatson.ae/section/active/outdoor/" class="hover-nav"><span>Outdoor</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/well-being/" class="hover-nav hover__dropdown"><span>Wellbeing</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/well-being/spas/" class="hover-nav"><span>Spas</span></a></li>
<li><a href="https://whatson.ae/section/well-being/beauty/" class="hover-nav"><span>Beauty</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/pets/" class="hover-nav"><span>Pets</span></a>
</li>
<li>
<a href="https://whatson.ae/section/shopping/" class="hover-nav"><span>Shopping</span></a>
</li>
<li>
<a href="https://whatson.ae/section/family/" class="hover-nav"><span>Family</span></a>
</li>
<li>
<a href="https://whatson.ae/section/competitions/" class="hover-nav"><span>Competitions</span></a>
</li>
<li><a href="https://whatson.ae/events/" class="hover-nav"><span>Events</span></a></li>
</ul>
</div>
</div>
</div>
</div>
<img src="https://pubads.g.doubleclick.net/activity;dc_iu=/21835097498/DFPAudiencePixel;ord=1;dc_seg=6575138653?" width=1 height=1 border=0/>
</header>

<div class="sticky__header">
<div class="sticky__header__inner max-width">
<div class="sticky__header__inner__flex_row">
<div class="header__logo-wrapper">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="250" alt="logo icon"></a>
</div>
<div class="header__bottom">
<div class="header__bottom__flex-row  max-width">
<div class="header__nav">
<ul class="header__nav__list">
<li class="header__nav__list__item "><a href="/section/news/">NEWS</a></li>
<li class="header__nav__list__item "><a href="/section/eat/">EAT &amp; DRINK</a></li>
<li class="header__nav__list__item "><a href="/section/things-to-do/">THINGS TO DO</a></li>
<li class="header__nav__list__item "><a href="/section/uae-50/">UAE 50</a></li>
<li class="header__nav__list__item "><a href="/cinema/">CINEMA</a></li>
<li class="header__nav__list__item "><a href="/section/culture/">CULTURE</a></li>
</ul>
 </div>
<div class="header__nav-more__flex-row">

<div class="header__search">
<form role="search" method="get" action="https://whatson.ae" class="header__nav-more__search search__form__">
<input type="text" name="s" value="" placeholder="Search">
</form>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/search.svg" width="16" class="search__icon" alt="search icon">
</div>
<div class="header__login">
<a href="http://local.whatson.ae/dubai/knowledge/2990/newsletter-sign-up/">SIGN UP</a>
</div>
<div class="header__nav-dropdown">
<a class="more-btn-anchor"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/menu-button.svg" width="26" class="more-down-btn" alt="menu icon"></a>
</div>
<ul class="header__nav-dropdown__sub-menu">
<li>
<a href="https://whatson.ae/section/nightlife/" class="hover-nav"><span>Nightlife</span></a>
</li>
<li>
<a href="https://whatson.ae/section/culture/" class="hover-nav hover__dropdown"><span>Culture</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/culture/film/" class="hover-nav"><span>Film</span></a></li>
<li><a href="https://whatson.ae/section/culture/theatre/" class="hover-nav"><span>Theatre</span></a></li>
<li><a href="https://whatson.ae/section/culture/art/" class="hover-nav"><span>Art</span></a></li>
<li><a href="https://whatson.ae/section/culture/technology/" class="hover-nav"><span>Tech</span></a></li>
<li><a href="https://whatson.ae/section/culture/workshops/" class="hover-nav"><span>Workshops</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/travel/" class="hover-nav hover__dropdown"><span>Travel</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/travel/travel-deals/" class="hover-nav"><span>Deals</span></a></li>
<li><a href="https://whatson.ae/section/travel/staycations/" class="hover-nav"><span>Staycations</span></a></li>
<li><a href="https://whatson.ae/section/travel/short-haul/" class="hover-nav"><span>Short Haul</span></a></li>
<li><a href="https://whatson.ae/section/travel/long-haul/" class="hover-nav"><span>Long Haul</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/active/" class="hover-nav hover__dropdown"><span>Sports & Fitness</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/active/workouts/" class="hover-nav"><span>Workouts</span></a></li>
<li><a href="https://whatson.ae/section/active/indoor/" class="hover-nav"><span>Indoor</span></a></li>
<li><a href="https://whatson.ae/section/active/outdoor/" class="hover-nav"><span>Outdoor</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/well-being/" class="hover-nav hover__dropdown"><span>Wellbeing</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/well-being/spas/" class="hover-nav"><span>Spas</span></a></li>
<li><a href="https://whatson.ae/section/well-being/beauty/" class="hover-nav"><span>Beauty</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/pets/" class="hover-nav"><span>Pets</span></a>
</li>
<li>
<a href="https://whatson.ae/section/shopping/" class="hover-nav"><span>Shopping</span></a>
</li>
<li>
<a href="https://whatson.ae/section/family/" class="hover-nav"><span>Family</span></a>
</li>
<li>
<a href="https://whatson.ae/section/competitions/" class="hover-nav"><span>Competitions</span></a>
</li>
<li><a href="https://whatson.ae/events/" class="hover-nav"><span>Events</span></a></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>

<header class="header-mobile">
<div class="header-mobile__inner">
<div class="header-mobile__flex-row">
<div class="header-mobile__signup">
<a href=""><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/female-icon.svg" width="18" alt="account icon"></a>
</div>
<div class="header-mobile__logo-wrapper">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="108" alt="logo icon"></a>
</div>
<div class="header-mobile__menu">
<a href="https://whatson.ae/knowledge/2990/newsletter-sign-up/" class="mobile__signup__btn">Sign up</a>
<div class="header-mobile__menu__inner">
<div class="header-mobile__menu__each"></div>
<div class="header-mobile__menu__each header-mobile__menu__each--wide"></div>
<div class="header-mobile__menu__each"></div>
</div>
</div>
</div>
<div class="header-mobile__menu__content">
<div class="header-mobile__menu__content__inner">
<div class="header-mobile__menu__content__inner">
<div class="header-mobile__menu__content__each ">
<a href="/section/news/">NEWS</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/eat/">EAT & DRINK</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/things-to-do/">THINGS TO DO</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/uae-50/">UAE 50</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/cinema/">CINEMA</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/culture/">CULTURE</a>
</div>
</div>
<div class="header-mobile__menu__search-more">
<div class="header-mobile__menu__search">
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/search.svg" width="16" class="search__icon" alt="search icon">
</div>
<form role="search" method="get" action="https://whatson.ae" class="header-mobile__menu__search__form search__form__">
<input type="text" name="s" value="" placeholder="Search" class="header-mobile__menu__search__textbox">
</form>
<div class="header-mobile__menu__more">
<a href="">MORE &nbsp;<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/down-arrow-white-new.svg" width="12" class="more-down-btn" alt="more button icon"></a>
</div>
</div>
<div>
<ul class="header-mobile__nav-dropdown__sub-menu">
<li>
<a href="https://whatson.ae/section/nightlife/" class="hover-nav"><span>Nightlife</span></a>
</li>
<li>
<a href="https://whatson.ae/section/culture/" class="hover-nav hover__dropdown"><span>Culture</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/culture/film/" class="hover-nav"><span>Film</span></a></li>
<li><a href="https://whatson.ae/section/culture/theatre/" class="hover-nav"><span>Theatre</span></a></li>
<li><a href="https://whatson.ae/section/culture/art/" class="hover-nav"><span>Art</span></a></li>
<li><a href="https://whatson.ae/section/culture/technology/" class="hover-nav"><span>Tech</span></a></li>
<li><a href="https://whatson.ae/section/culture/workshops/" class="hover-nav"><span>Workshops</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/travel/" class="hover-nav hover__dropdown"><span>Travel</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/travel/travel-deals/" class="hover-nav"><span>Deals</span></a></li>
<li><a href="https://whatson.ae/section/travel/staycations/" class="hover-nav"><span>Staycations</span></a></li>
<li><a href="https://whatson.ae/section/travel/short-haul/" class="hover-nav"><span>Short Haul</span></a></li>
<li><a href="https://whatson.ae/section/travel/long-haul/" class="hover-nav"><span>Long Haul</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/active/" class="hover-nav hover__dropdown"><span>Sports & Fitness</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/active/workouts/" class="hover-nav"><span>Workouts</span></a></li>
<li><a href="https://whatson.ae/section/active/indoor/" class="hover-nav"><span>Indoor</span></a></li>
<li><a href="https://whatson.ae/section/active/outdoor/" class="hover-nav"><span>Outdoor</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/well-being/" class="hover-nav hover__dropdown"><span>Wellbeing</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/well-being/spas/" class="hover-nav"><span>Spas</span></a></li>
<li><a href="https://whatson.ae/section/well-being/beauty/" class="hover-nav"><span>Beauty</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/pets/" class="hover-nav"><span>Pets</span></a>
</li>
<li>
<a href="https://whatson.ae/section/shopping/" class="hover-nav"><span>Shopping</span></a>
</li>
<li>
<a href="https://whatson.ae/section/family/" class="hover-nav"><span>Family</span></a>
</li>
<li>
<a href="https://whatson.ae/section/competitions/" class="hover-nav"><span>Competitions</span></a>
</li>
<li><a href="https://whatson.ae/events/" class="hover-nav"><span>Events</span></a></li>
</ul>
</div>
<div class="header-mobile___signup">
<div class="header-mobile___signup__btn">
SIGN UP & CUSTOMISE
</div>
</div>
</div>
</div>
</div>
</header>
<div class="article-content max-width">
<div style="position:absolute;left:-170px; width: 160px;height: 600px;" class="show__desktop">

<div id='div-gpt-ad-1584618353125-0' style='width: 160px; height: 600px;'>
<script>
                                    googletag.cmd.push(function() {  
                                        googletag.display('div-gpt-ad-1584618353125-0');                           
                                     });
                                  </script>
</div>
</div>
<div style="position:absolute; right:-170px; width: 160px;height: 600px;" class="show__desktop">

<div id='div-gpt-ad-1584618353125-1' style='width: 160px; height: 600px;'>
<script>
                                    googletag.cmd.push(function() {  
                                        googletag.display('div-gpt-ad-1584618353125-1');                             
                                     });
                                  </script>
</div>
</div>
<div class="article-content__inner">
<div class="article-content__flex-row">
<div class="article-content__left">

<div class="article-content__left__top">
<div class="article-content__image lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg)">
</div>

<h1 class="article-content__title">
<span class="outerSpan">
<span class="innerSpan">
American megastar Flo Rida to perform in Dubai this week </span>
</span>
</h1>
</div>
<div class="article-content__meta">

<div class="article-content__social">
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="fb" data-link="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" data-picture="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg" data-name="American megastar Flo Rida to perform in Dubai this week" data-caption="American megastar Flo Rida to perform in Dubai this week" data-description="It&#8217;s going down for real&#8230; Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week. Taking to the stage at Blu Dubai, the American&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/facebook.svg" width="38" alt="facebook follow"></a>
</div>
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="tw" data-link="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" data-picture="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg" data-name="American megastar Flo Rida to perform in Dubai this week" data-caption="American megastar Flo Rida to perform in Dubai this week" data-description="It&#8217;s going down for real&#8230; Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week. Taking to the stage at Blu Dubai, the American&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/twitter.svg" width="38" alt="twitter follow"></a>
</div>
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="whatsapp" data-link="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" data-picture="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg" data-name="American megastar Flo Rida to perform in Dubai this week" data-caption="American megastar Flo Rida to perform in Dubai this week" data-description="It&#8217;s going down for real&#8230; Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week. Taking to the stage at Blu Dubai, the American&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/whatsapp.svg" width="38" alt="whatsapp follow"></a>
</div>
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="mail" data-link="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" data-picture="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg" data-name="American megastar Flo Rida to perform in Dubai this week" data-caption="American megastar Flo Rida to perform in Dubai this week" data-description="It&#8217;s going down for real&#8230; Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week. Taking to the stage at Blu Dubai, the American&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/mail.svg" width="38" alt="mail follow"></a>
</div>
</div>

<div class="article-content__tags article-content__tags--top">
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/nightlife/clubs/">
Clubs </a>
</div>
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/nightlife/">
Nightlife </a>
</div>
</div>

<div class="article-content__author">
<div class="article-content__author__image">
<img alt='Elise Kerr' src='https://whatson.ae/dubai/wp-content/uploads/2019/02/Elise-Kerr_avatar_1550390716.jpg' class='avatar avatar-45 photo' height='45' width='45' /> </div>
<div class="article-content__author__detail">
Written by: <br><strong> Elise Kerr </strong><br>
21 hours ago </div>
</div>
</div>

<div class="article-content__description">
<div class="article-text"><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"><h4>It&rsquo;s going down for real&hellip;</h4><p>Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week. Taking to the stage at <a href="https://whatson.ae/2021/03/boa-dubai-has-closed-forever-heres-what-will-replace-it/" target="_blank" rel="noopener noreferrer">Blu Dubai</a>, the American rapper will perform for one night only, on Wednesday August 11.</p><p>Known for huge hits such as&nbsp;<em>Wild Ones ft Sia</em>,<em> My House</em>,<em> Good Feeling</em>,<em> Low</em>,<em> Whistle</em>, and many more, fans can expect a plethora of hits on the night.</p><div class="gallery__empty"></div><p>Blu Dubai is located on the 32nd floor of V-Hotel Dubai in Al Habtoor City, which in a matter of weeks since it launched, has already played host to performers such as <a href="https://whatson.ae/2021/06/new-dubai-nightclub-to-open-in-v-hotel-this-weekend/" target="_blank" rel="noopener noreferrer">Trey Songz</a>, Gims, and <a href="https://whatson.ae/2021/07/rick-ross-to-perform-live-in-dubai-this-weekend/" target="_blank" rel="noopener noreferrer">Rick Ross</a>.</p><div class="instagram-feed"><blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 540px; min-width: 326px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/p/CSR4kM5I-F5/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13">
<div style="padding: 16px;">
<p>&nbsp;</p>
<div style="display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display: block; height: 50px; margin: 0 auto 12px; width: 50px;"></div>
<div style="padding-top: 8px;">
<div style="color: #3897f0; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: 550; line-height: 18px;">View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #f4f4f4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style="width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg);"></div>
</div>
<div style="margin-left: auto;">
<div style="width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style="background-color: #f4f4f4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style="width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;">
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div>
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div>
</div>
<p>&nbsp;</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;"><a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none;" href="https://www.instagram.com/p/CSR4kM5I-F5/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer">A post shared by CLUB BLU DUBAI (@clubbludubai)</a></p>
</div>
</blockquote></div><div class="empty-ad removeFloat"></div><div class="youmayalso__empty"><div></div></div><p><script async src="//www.instagram.com/embed.js"></script></p><p>The club won&rsquo;t be issuing any tickets for the event, so if you want to attend you&rsquo;ll need to get your mates together and book a table. Tables start from Dhs3,000.</p><p>Giving us all the vibes of nostalgia, Flo Rida was most popular between the years of 2007 and 2012, when&nbsp;<em>Low</em> was playing in every club, but he&rsquo;s still making catchy tracks to this day.</p><p>No stranger to Dubai, Flo Rida has performed at Drai&rsquo;s Dubai, White Dubai, Cavalli Club and Cirque Le Soir, back in the day.</p><p><em>Blu Dubai, V Hotel, Al Habtoor City, Wednesday August 11, 10pm onwards, tables from Dhs3,000. Tel: (0)56 501 2039. <a href="https://www.instagram.com/clubbludubai/" target="_blank" rel="noopener noreferrer">@clubbludubai</a></em></p><p><em>Image: Instagram</em></p></div><p></p>

<div class="article-content__sign-up">
<div class="article-content__sign-up__btn hover-opacity">
<a href="https://whatson.ae/knowledge/2990/newsletter-sign-up/">
Sign up!
</a>
</div>
<div class="article-content__sign-up__text">
> Sign up for FREE to get exclusive updates that you are interested in
</div>
</div>

<div class="article-content__footer-meta">
<div class="article-content__footer-meta__social">
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="fb" data-link="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" data-picture="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg" data-name="American megastar Flo Rida to perform in Dubai this week" data-caption="American megastar Flo Rida to perform in Dubai this week" data-description="It&#8217;s going down for real&#8230; Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week. Taking to the stage at Blu Dubai, the American&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/facebook.svg" width="38" alt="facebook follow"></a>
</div>
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="tw" data-link="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" data-picture="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg" data-name="American megastar Flo Rida to perform in Dubai this week" data-caption="American megastar Flo Rida to perform in Dubai this week" data-description="It&#8217;s going down for real&#8230; Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week. Taking to the stage at Blu Dubai, the American&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/twitter.svg" width="38" alt="twitter follow"></a>
</div>
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="whatsapp" data-link="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" data-picture="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg" data-name="American megastar Flo Rida to perform in Dubai this week" data-caption="American megastar Flo Rida to perform in Dubai this week" data-description="It&#8217;s going down for real&#8230; Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week. Taking to the stage at Blu Dubai, the American&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/whatsapp.svg" width="38" alt="whatsapp follow"></a>
 </div>
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="mail" data-link="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" data-picture="https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg" data-name="American megastar Flo Rida to perform in Dubai this week" data-caption="American megastar Flo Rida to perform in Dubai this week" data-description="It&#8217;s going down for real&#8230; Clear your calendars music-fans as superstar performer Flo Rida will be returning to Dubai this week. Taking to the stage at Blu Dubai, the American&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/mail.svg" width="38" alt="mail follow"></a>
</div>
</div>

<div class="article-content__footer-meta__tags">
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/nightlife/clubs/" style="color:white; font-weight: 400;">
Clubs </a>
</div>
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/nightlife/" style="color:white; font-weight: 400;">
Nightlife </a>
</div>
</div>
</div>
</div>
</div>

<div class="article-content__right">

<div class="article-content--top-right-parent">
<div class="ad-wrapper article-content--top-right">
<div class="ad-wrapper__inner add__with__bg">
<div class="ad-wrapper__300x250">

<div class="">

<div id='div-gpt-ad-1594276737606-0'>
<script>
                                                googletag.cmd.push(function() { 
                                                    googletag.display('div-gpt-ad-1594276737606-0'); 
                                                });
                                            </script>
</div>
</div>
</div>
</div>
</div>
</div>

<div class="special-articles special-articles--right-side editors-pick__styl2">
<div class="article-content__title-without-bg">
<div class="article-content__title-without-bg__text">EDITOR’S PICKS</div>
</div>
<div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/08/is-it-real-emirates-flight-attendant-stands-on-top-of-burj-khalifa/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/08/emirates-burj-khalifa-ft.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/08/is-it-real-emirates-flight-attendant-stands-on-top-of-burj-khalifa/">
<span class="outerSpan">
<span class="innerSpan">
Is it real? Emirates flight attendant stands on top of Burj Khalifa
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/08/is-it-real-emirates-flight-attendant-stands-on-top-of-burj-khalifa/">READ MORE</a>
</div>
</div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/08/its-back-whats-on-lock-in-heads-to-crowne-plaza-dubai-jumeirah-in-september/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/08/Lock-In-Crowne-Plaza-main.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/08/its-back-whats-on-lock-in-heads-to-crowne-plaza-dubai-jumeirah-in-september/">
<span class="outerSpan">
<span class="innerSpan">
It's back! What's On Lock In heads to Crowne Plaza Dubai Jumeirah in September
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/08/its-back-whats-on-lock-in-heads-to-crowne-plaza-dubai-jumeirah-in-september/">READ MORE</a>
</div>
</div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/08/uae-residents-stranded-in-india-pakistan-and-more-allowed-to-return/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/08/getty-flight-stranded-india-to-uae-featured.jpg)">
 </a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/08/uae-residents-stranded-in-india-pakistan-and-more-allowed-to-return/">
<span class="outerSpan">
<span class="innerSpan">
UAE residents stranded in India, Pakistan and more allowed to return
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/08/uae-residents-stranded-in-india-pakistan-and-more-allowed-to-return/">READ MORE</a>
</div>
</div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/08/resident-returning-to-the-uae-theres-a-new-form-to-fill-out-for-approval/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2020/05/man-waiting-for-flight-airport.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/08/resident-returning-to-the-uae-theres-a-new-form-to-fill-out-for-approval/">
<span class="outerSpan">
<span class="innerSpan">
Resident returning to the UAE? Here's the approval form
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/08/resident-returning-to-the-uae-theres-a-new-form-to-fill-out-for-approval/">READ MORE</a>
</div>
</div>
</div>
</div>

<div class="ad-wrapper">
<div class="ad-wrapper__inner add__with__bg">
<div class="ad-wrapper__300x600">

<div class="">
<div id='div-gpt-ad-1564916122119-0'>
<script>
                                            googletag.cmd.push(function() { 
                                                googletag.display('div-gpt-ad-1564916122119-0'); 
                                            });
                                        </script>
</div>
</div>
</div>
</div>
</div>

<div class="special-articles--right-side">
<div class="special-articles">
<div class="special-articles__title">
<span>MOST POPULAR</span>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/08/5-of-this-summers-biggest-adventures-at-the-galleria/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/08/The-Galleria-feat-2-.jpeg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/08/5-of-this-summers-biggest-adventures-at-the-galleria/">
5 big adventures at The Galleria this summer </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/08/3-fun-new-brunches-to-try-in-dubai-this-weekend/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/08/new-brunches-dubai-featured.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/08/3-fun-new-brunches-to-try-in-dubai-this-weekend/">
3 fun new brunches to try in Dubai this weekend </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/08/this-sky-high-restaurant-launches-a-blind-wine-tasting-dinner-series/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/08/weslodge-wine-tasting-featured.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/08/this-sky-high-restaurant-launches-a-blind-wine-tasting-dinner-series/">
This sky-high restaurant launches a 'blind wine tasting' dinner series </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/08/8-mega-things-to-do-in-abu-dhabi-this-week-aug-8-to-11/" style="background-image: url(https://whatson.ae/wp-content/uploads/2020/07/Abu-Dhabi-Skyline-city-FEAT.jpeg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/08/8-mega-things-to-do-in-abu-dhabi-this-week-aug-8-to-11/">
8 mega things to do in Abu Dhabi this week: Aug 8 to 11 </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/08/flo-rida-dubai-ft.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/08/american-megastar-flo-rida-to-perform-in-dubai-this-week/">
American megastar Flo Rida to perform in Dubai this week </a>
</div>
</div>
</div>
</div>
</div>

<div class="checkArticleHalfpage"></div>
<div class="ad-wrapper second__MPU hp_floatAd">
<div class="ad-wrapper__inner add__with__bg">
<div class="ad-wrapper__300x250">

<div class="">
<div id='div-gpt-ad-1564916076259-0'>
<script>
                                            googletag.cmd.push(function() { 
                                                googletag.display('div-gpt-ad-1564916076259-0'); 
                                            });
                                        </script>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<div class="article-content__title-without-bg you__should__also">
<div class="article-content__title-without-bg__text">YOU SHOULD CHECK OUT</div>
</div>
<div class="load__home__content" data-category="nightlife">
</div>
</div> 
</div> 
<footer>
</footer>
</div> 
</div> 
<footer class="footer__wrapper">
<div class="footer__wrapper__inner max-width">
<div class="footer__menu">
<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-824" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-824"><a href="https://whatson.ae/about/advertising/">Advertise with us</a></li>
<li id="menu-item-825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-825"><a href="https://whatson.ae/about/legal/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-827" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-827"><a href="https://whatson.ae/about/">About Motivate</a></li>
</ul></div> </div>
<div class="footer__copyright">
<p class="">Motivate Media Group © 2021</p>
</div>
</div>
</footer>
<div id='fb-pxl-ajax-code'></div>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/ab2d0.js"></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctcc_vars = {"expiry":"30","method":"1","version":"1"};
/* ]]> */
</script>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/60ad6.js"></script>
<script type="text/javascript">
					jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
																	});
				</script>
<div id="catapult-cookie-bar" class=""><div class="ctcc-inner "><span class="ctcc-left-side">Our website uses cookies and other similar technologies to improve our site and your online experience. By continuing to use our website you consent to cookies being used. <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://whatson.ae/about/legal/privacy-policy/">Read our privacy policy here.</a></span><span class="ctcc-right-side"><button id="catapultCookie" tabindex=0 onclick="catapultAcceptCookies();">Okay, thanks</button></span></div></div>
<script type="text/javascript">
    adroll_adv_id = "J636N26HTRH3HF2B3FJ6YO";
    adroll_pix_id = "RKAQBLXCRBAWDEYT7X6FNW";
    (function () {
        var oldonload = window.onload;
        window.onload = function(){
            __adroll_loaded=true;
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
             document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
            if(oldonload){oldonload()}};
    }());
</script>
<script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
<script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>
<script src="https://tags.crwdcntrl.net/c/8987/cc_af.js"></script>
<img src="//qa-gmtdmp.mookie1.com/t/v2/learn?tagid=V2_10308&src.rand=[timestamp]&src.id=[optionally replace with unique identifier]" style="display:none;" />
<script type="text/javascript">
    adroll_adv_id = "J636N26HTRH3HF2B3FJ6YO";
    adroll_pix_id = "RKAQBLXCRBAWDEYT7X6FNW";
    (function () {
    var oldonload = window.onload;
    window.onload = function(){
       __adroll_loaded=true;
       var scr = document.createElement("script");
       var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
       scr.setAttribute('async', 'true');
       scr.type = "text/javascript";
       scr.src = host + "/j/roundtrip.js";
       ((document.getElementsByTagName('head') || [null])[0] ||
        document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
       if(oldonload){oldonload()}};
    }());
</script>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/7a133.js"></script>
<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/106581/tag"></script>
<script type="text/javascript">
    $(window).load(function()
    {
        masonryContent();
    });
</script>
</body></html>
