<!DOCTYPE html>
<html lang="en-GB">
<head><link rel="stylesheet" type="text/css" href="https://whatson.ae/wp-content/cache/minify/8f4f3.css" media="all" />
<meta charset="UTF-8">
<title>10 awesome things you need to do this weekend: May 20 to 22</title>
<meta name="keywords" content="" />

<meta name="viewport" content="width=device-width, user-scalable=no" />

<meta name="description" content="Now that things are back to normal, with the reintroduction of brunches and live entertainment, we reckon this weekend is going to be huge." />
<link rel="original-source" href="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" />
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
<link rel="canonical" href="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="10 awesome things you need to do this weekend: May 20 to 22" />
<meta property="og:description" content="It&#039;s nearly here..." />
<meta property="og:url" content="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" />
<meta property="og:site_name" content="What&#039;s On" />
<meta property="article:publisher" content="https://www.facebook.com/WhatsOnDubai" />
<meta property="article:tag" content="dubai weekend" />
<meta property="article:tag" content="things to do" />
<meta property="article:tag" content="things to do weekend" />
<meta property="article:tag" content="weekend dubai" />
<meta property="article:tag" content="what to do in dubai" />
<meta property="article:section" content="Things to do" />
<meta property="article:published_time" content="2021-05-19T08:07:44+00:00" />
<meta property="article:modified_time" content="2021-05-19T08:14:07+00:00" />
<meta property="og:updated_time" content="2021-05-19T08:14:07+00:00" />
<meta property="fb:app_id" content="521837017887988" />
<meta property="og:image" content="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-fb.jpg" />
<meta property="og:image:secure_url" content="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-fb.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="627" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Now that things are back to normal, with the reintroduction of brunches and live entertainment, we reckon this weekend is going to be huge." />
<meta name="twitter:title" content="10 awesome things you need to do this weekend: May 20 to 22" />
<meta name="twitter:site" content="@WhatsOnDubai" />
<meta name="twitter:image" content="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-fb.jpg" />
<meta name="twitter:creator" content="@WhatsOnDubai" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://whatson.ae/#website","url":"https://whatson.ae/","name":"What&#039;s On","description":"Things to do in Dubai &amp; the UAE","potentialAction":{"@type":"SearchAction","target":"https://whatson.ae/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/#primaryimage","url":"https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-feat.jpg","width":800,"height":440,"caption":"things-to-do-dubai-weekend-may-20"},{"@type":"WebPage","@id":"https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/#webpage","url":"https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/","inLanguage":"en-GB","name":"10 awesome things you need to do this weekend: May 20 to 22","isPartOf":{"@id":"https://whatson.ae/#website"},"primaryImageOfPage":{"@id":"https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/#primaryimage"},"datePublished":"2021-05-19T08:07:44+00:00","dateModified":"2021-05-19T08:14:07+00:00","author":{"@id":"https://whatson.ae/#/schema/person/3aba97a61c9af35278ecb0770a9431ed"},"description":"Now that things are back to normal, with the reintroduction of brunches and live entertainment, we reckon this weekend is going to be huge."},{"@type":["Person"],"@id":"https://whatson.ae/#/schema/person/3aba97a61c9af35278ecb0770a9431ed","name":"Lauren Fletcher","image":{"@type":"ImageObject","@id":"https://whatson.ae/#authorlogo","url":"https://secure.gravatar.com/avatar/14b16148f6ba078bfb8c537c9964755d?s=96&d=mm&r=g","caption":"Lauren Fletcher"},"sameAs":[]}]}</script>

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="What&#039;s On &raquo; 10 awesome things you need to do this weekend: May 20 to 22 Comments Feed" href="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/whatson.ae\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/df983.js"></script>
<link rel='https://api.w.org/' href='https://whatson.ae/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://whatson.ae/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://whatson.ae/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.3.8" />
<link rel='shortlink' href='https://whatson.ae/?p=200327' />
<link rel="alternate" type="application/json+oembed" href="https://whatson.ae/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhatson.ae%2F2021%2F05%2F10-awesome-things-you-need-to-do-this-weekend-may-20-to-22%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://whatson.ae/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwhatson.ae%2F2021%2F05%2F10-awesome-things-you-need-to-do-this-weekend-may-20-to-22%2F&#038;format=xml" />
<meta property="fb:pages" content="133671683313479" />
<meta property="ia:markup_url" content="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/?ia_markup=1" />
<style id="ctcc-css" type="text/css" media="screen">
				#catapult-cookie-bar {
					box-sizing: border-box;
					max-height: 0;
					opacity: 0;
					z-index: 99999;
					overflow: hidden;
					color: #ddd;
					position: fixed;
					left: 0;
					bottom: 0;
					width: 100%;
					background-color: #000000;
				}
				#catapult-cookie-bar a {
					color: #fff;
				}
				#catapult-cookie-bar .x_close span {
					background-color: #000000;
				}
				button#catapultCookie {
					background:#ffffff;
					color: #000000;
					border: 0; padding: 6px 9px; border-radius: 3px;
				}
				#catapult-cookie-bar h3 {
					color: #ddd;
				}
				.has-cookie-bar #catapult-cookie-bar {
					opacity: 1;
					max-height: 999px;
					min-height: 30px;
				}</style>

<meta name="wp-parsely_version" id="wp-parsely_version" content="2.0" />
<script type="application/ld+json">
		{"@context":"http:\/\/schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/whatson.ae\/2021\/05\/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22\/"},"headline":"10 awesome things you need to do this weekend: May 20 to 22","url":"https:\/\/whatson.ae\/2021\/05\/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22\/","thumbnailUrl":"https:\/\/whatson.ae\/wp-content\/uploads\/2021\/05\/things-to-do-dubai-weekend-may-20-feat.jpg","image":{"@type":"ImageObject","url":"https:\/\/whatson.ae\/wp-content\/uploads\/2021\/05\/things-to-do-dubai-weekend-may-20-feat.jpg"},"dateCreated":"2021-05-19T08:07:44Z","datePublished":"2021-05-19T08:07:44Z","dateModified":"2021-05-19T08:07:44Z","articleSection":"Best of","author":[{"@type":"Person","name":"Lauren Fletcher"}],"creator":["Lauren Fletcher"],"keywords":["dubai weekend","things to do","things to do weekend","weekend dubai","what to do in dubai"],"publisher":{"@type":"Organization","name":"What&#039;s On","logo":{"@type":"ImageObject","url":""}}}
		</script>


<script type='text/javascript'>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','https://connect.facebook.net/en_US/fbevents.js');
</script>

<script type='text/javascript'>
  fbq('init', '301969470674972', {}, {
    "agent": "wordpress-5.3.8-3.0.0"
});
</script><script type='text/javascript'>
  fbq('track', 'PageView', []);
</script>

<noscript>
<img height="1" width="1" style="display:none" alt="fbpx"
src="https://www.facebook.com/tr?id=301969470674972&ev=PageView&noscript=1" />
</noscript>

<style>.twentytwenty-container { margin-bottom: 5px ; background-color:#666666;}
    .smallcaption { font-size: 11px; color: #666666; margin-bottom: 15px;}
    .instagram-media { width:100%; }
    </style>
<link rel="stylesheet" href="https://whatson.ae/wp-content/themes/whatson-grow/js/royalslider/skins/default/rs-default.css">
<script src="https://whatson.ae/wp-content/themes/whatson-grow/js/royalslider/jquery.royalslider.min.js"></script>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/ae1ea.js"></script>
<style>.royalSlider {
      width: 100%;
      height: 412px;
    }</style>

<script type="text/javascript">
		window.bk_async = function() {
		 // ALLOW MULTIPLE CALLS/SINGLE PAGE APPS
		bk_allow_multiple_calls=true; bk_use_multiple_iframes=true ;
		 // <optional> PHINTS : Declare variables about this page (or user)
		bk_addPageCtx('page_type', 'Article'); // example phint (change to your own useful variabes)
		bk_addPageCtx('section', 'Best of,Things to do'); // example phint (change to your own useful variabes)
		bk_addPageCtx('article_ID', '200327'); // article_ID
		bk_addPageCtx("article_name", "10 awesome things you need to do this weekend: May 20 to 22"); // headline of article
		bk_addPageCtx("city", "Dubai"); // City		
		bk_addPageCtx("tag", "dubai weekend, things to do, things to do weekend, weekend dubai, what to do in dubai, "); // Tags		 
		 
		  // Send Data
		BKTAG.doTag(43849, 4);  // change "ENTER CONTAINER ID HERE" to the container ID/Site ID you want to use
		};
		(function() {
		  var scripts = document.getElementsByTagName('script')[0];
		  var s = document.createElement('script');
		  s.async = true;
		  s.src = "//tags.bkrtx.com/js/bk-coretag.js";
		  scripts.parentNode.insertBefore(s, scripts);
		}());
	</script>

<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/ff6a4.js"></script>

<script type="text/javascript">
	var _elqQ = _elqQ || [];
	_elqQ.push(['elqSetSiteId', '1244214268']);
	_elqQ.push(['elqTrackPageView']);

	(function () {
	    function async_load() {
	        var s = document.createElement('script'); s.type = 'text/javascript'; s.async = true;
	        s.src = '//img04.en25.com/i/elqCfg.min.js';
	        var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
	    }
	    if (window.addEventListener) window.addEventListener('DOMContentLoaded', async_load, false);
	    else if (window.attachEvent) window.attachEvent('onload', async_load);
	})();
</script>

<script id="parsely-cfg" data-parsely-site="whatson.ae" src="//cdn.parsely.com/keys/whatson.ae/p.js"></script>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-13044993-17"></script>
<script>
        window.dataLayer = window.dataLayer || [];
        function gtag(){dataLayer.push(arguments);}
        gtag('js', new Date());

        gtag('config', 'UA-13044993-17');
    </script>
<link href="https://fonts.googleapis.com/css?family=Lato:400,700" rel="stylesheet">
<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
                var gads = document.createElement('script');
                gads.async = true;
                gads.type = 'text/javascript';
                var useSSL = 'https:' == document.location.protocol;
                gads.src = (useSSL ? 'https:' : 'http:') +
                    '//www.googletagservices.com/tag/js/gpt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(gads, node);
            })();
        </script>
<script type='text/javascript'>
    var skinAd;
    var lbAd;
    var mobLbAd;
    var catfishAd;
    window.googletag = window.googletag || {cmd: []};
    googletag.cmd.push(function() {

googletag.defineSlot('/21835097498/WhatsOn_ThingsToDo_LBBB', [[728, 90], [970, 250]], 'div-gpt-ad-1564915633592-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_ThingsToDo_MPU_ATF', [300, 250], 'div-gpt-ad-1594287178696-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_ThingsToDo_MPU', [300, 250], 'div-gpt-ad-1564915694174-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_ThingsToDo_HP', [300, 600], 'div-gpt-ad-1564915739711-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_ThingsToDo_Skyscraper', [160, 600], 'div-gpt-ad-1604477721480-0').addService(googletag.pubads());
googletag.defineSlot('/21835097498/WhatsOn_ThingsToDo_Skyscraper', [160, 600], 'div-gpt-ad-1604477721480-1').addService(googletag.pubads());
googletag.pubads().setTargeting('Interests', ['Best of' , 'Things to do' ]);    googletag.pubads().disableInitialLoad();
    googletag.pubads().enableSingleRequest(); 
    googletag.pubads().collapseEmptyDivs(); 
    googletag.enableServices();
    googletag.pubads().refresh();

    googletag.pubads().addEventListener('slotRenderEnded', function(event) {
        console.log('Creative with id: ' + event.creativeId +
        ' is rendered to slot of size: ' + event.size[0] + 'x' + event.size[1]);

        if(event.size[0] == 728 ){
            $('.header__ad-leader-board').css('height', event.size[1]);
        }

        if(event.size[0] == 970 ){
            $('.header__ad-leader-board').css('height', event.size[1]);
            $('.header').addClass('billboardAd');
        }

    });
    
});
</script>
</head>
<body data-rsssl=1 class="post-template-default single single-post postid-200327 single-format-standard">
<script type="text/javascript">
        var ajaxUrl = 'https://whatson.ae/wp-admin/admin-ajax.php';
        var baseUrl = 'https://whatson.ae';
        var tempUrl = 'https://whatson.ae/wp-content/themes/whatson-grow';
    </script>
<div class="wo__container">
<div class="wrapper" id="wrapper">

<header class="header header--desktop">
<div class="header--desktop__inner">
<div class="header__top">
<div class="header__top__flex-row  max-width">
<div class="header__logo__flex-row">
<div class="header__logo-wrapper">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="250" alt="logo icon"></a>
</div>
<div class="header__ad-leader-board">
<div class="header_ad-728x90">

<div id='div-gpt-ad-1564915633592-0'>
<script>
                                            googletag.cmd.push(function() {
                                                googletag.display('div-gpt-ad-1564915633592-0'); 
                                            });
                                        </script>
</div>
</div>
</div>
</div>
<div class="header__signup">
<a href="">Signup & Customize</a>
</div>
</div>
</div>
<div class="header__bottom">
<div class="header__bottom__flex-row  max-width">
<div class="header__nav">
<ul class="header__nav__list">
<li class="logo__inline">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="100" alt="logo icon"></a>
</li>
<li class="header__nav__list__item "><a href="/section/news/">NEWS</a></li>
<li class="header__nav__list__item "><a href="/section/eat/">EAT & DRINK</a></li>
<li class="header__nav__list__item "><a href="/section/things-to-do/">THINGS TO DO</a></li>
<li class="header__nav__list__item "><a href="/section/nightlife/">NIGHTLIFE</a></li>
<li class="header__nav__list__item "><a href="/cinema/">CINEMA</a></li>
<li class="header__nav__list__item "><a href="/section/culture/">CULTURE</a></li>
</ul>
</div>
<div class="header__nav-more__flex-row">

<div class="header__search">
<form role="search" method="get" action="https://whatson.ae" class="header__nav-more__search search__form__">
<input type="text" name="s" value="" placeholder="Search">
</form>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/search.svg" width="16" class="search__icon" alt="search icon">
</div>
<div class="header__login">
<a href="https://whatson.ae/knowledge/2990/newsletter-sign-up/">SIGN UP</a>
</div>
<div class="header__nav-dropdown">
<a class="more-btn-anchor"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/menu-button.svg" width="26" class="more-down-btn" alt="menu button icon"></a>
</div>
<ul class="header__nav-dropdown__sub-menu">
<li>
<a href="https://whatson.ae/section/culture/" class="hover-nav hover__dropdown"><span>Culture</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/culture/film/" class="hover-nav"><span>Film</span></a></li>
<li><a href="https://whatson.ae/section/culture/theatre/" class="hover-nav"><span>Theatre</span></a></li>
<li><a href="https://whatson.ae/section/culture/art/" class="hover-nav"><span>Art</span></a></li>
<li><a href="https://whatson.ae/section/culture/technology/" class="hover-nav"><span>Tech</span></a></li>
<li><a href="https://whatson.ae/section/culture/workshops/" class="hover-nav"><span>Workshops</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/travel/" class="hover-nav hover__dropdown"><span>Travel</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/travel/travel-deals/" class="hover-nav"><span>Deals</span></a></li>
<li><a href="https://whatson.ae/section/travel/staycations/" class="hover-nav"><span>Staycations</span></a></li>
<li><a href="https://whatson.ae/section/travel/short-haul/" class="hover-nav"><span>Short Haul</span></a></li>
<li><a href="https://whatson.ae/section/travel/long-haul/" class="hover-nav"><span>Long Haul</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/active/" class="hover-nav hover__dropdown"><span>Sports & Fitness</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/active/workouts/" class="hover-nav"><span>Workouts</span></a></li>
<li><a href="https://whatson.ae/section/active/indoor/" class="hover-nav"><span>Indoor</span></a></li>
<li><a href="https://whatson.ae/section/active/outdoor/" class="hover-nav"><span>Outdoor</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/well-being/" class="hover-nav hover__dropdown"><span>Wellbeing</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/well-being/spas/" class="hover-nav"><span>Spas</span></a></li>
<li><a href="https://whatson.ae/section/well-being/beauty/" class="hover-nav"><span>Beauty</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/pets/" class="hover-nav"><span>Pets</span></a>
</li>
<li>
<a href="https://whatson.ae/section/shopping/" class="hover-nav"><span>Shopping</span></a>
</li>
<li>
<a href="https://whatson.ae/section/family/" class="hover-nav"><span>Family</span></a>
</li>
<li>
<a href="https://whatson.ae/section/competitions/" class="hover-nav"><span>Competitions</span></a>
</li>
<li><a href="https://whatson.ae/events/" class="hover-nav"><span>Events</span></a></li>
</ul>
</div>
</div>
</div>
</div>
<img src="https://pubads.g.doubleclick.net/activity;dc_iu=/21835097498/DFPAudiencePixel;ord=1;dc_seg=6575138653?" width=1 height=1 border=0/>
</header>

<div class="sticky__header">
<div class="sticky__header__inner max-width">
<div class="sticky__header__inner__flex_row">
<div class="header__logo-wrapper">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="250" alt="logo icon"></a>
</div>
<div class="header__bottom">
<div class="header__bottom__flex-row  max-width">
<div class="header__nav">
<ul class="header__nav__list">
<li class="header__nav__list__item "><a href="/section/news/">NEWS</a></li>
<li class="header__nav__list__item "><a href="/section/eat/">EAT &amp; DRINK</a></li>
<li class="header__nav__list__item "><a href="/section/things-to-do/">THINGS TO DO</a></li>
<li class="header__nav__list__item "><a href="/section/nightlife/">NIGHTLIFE</a></li>
<li class="header__nav__list__item "><a href="/cinema/">CINEMA</a></li>
<li class="header__nav__list__item "><a href="/section/culture/">CULTURE</a></li>
</ul>
</div>
<div class="header__nav-more__flex-row">


<div class="header__login">
<a href="http://local.whatson.ae/dubai/knowledge/2990/newsletter-sign-up/">SIGN UP</a>
</div>
<div class="header__nav-dropdown">
<a class="more-btn-anchor"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/menu-button.svg" width="26" class="more-down-btn" alt="menu icon"></a>
</div>
<ul class="header__nav-dropdown__sub-menu">
<li>
<a href="https://whatson.ae/section/culture/" class="hover-nav hover__dropdown"><span>Culture</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/culture/film/" class="hover-nav"><span>Film</span></a></li>
<li><a href="https://whatson.ae/section/culture/theatre/" class="hover-nav"><span>Theatre</span></a></li>
<li><a href="https://whatson.ae/section/culture/art/" class="hover-nav"><span>Art</span></a></li>
<li><a href="https://whatson.ae/section/culture/technology/" class="hover-nav"><span>Tech</span></a></li>
<li><a href="https://whatson.ae/section/culture/workshops/" class="hover-nav"><span>Workshops</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/travel/" class="hover-nav hover__dropdown"><span>Travel</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/travel/travel-deals/" class="hover-nav"><span>Deals</span></a></li>
<li><a href="https://whatson.ae/section/travel/staycations/" class="hover-nav"><span>Staycations</span></a></li>
<li><a href="https://whatson.ae/section/travel/short-haul/" class="hover-nav"><span>Short Haul</span></a></li>
<li><a href="https://whatson.ae/section/travel/long-haul/" class="hover-nav"><span>Long Haul</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/active/" class="hover-nav hover__dropdown"><span>Sports & Fitness</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/active/workouts/" class="hover-nav"><span>Workouts</span></a></li>
<li><a href="https://whatson.ae/section/active/indoor/" class="hover-nav"><span>Indoor</span></a></li>
<li><a href="https://whatson.ae/section/active/outdoor/" class="hover-nav"><span>Outdoor</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/well-being/" class="hover-nav hover__dropdown"><span>Wellbeing</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/well-being/spas/" class="hover-nav"><span>Spas</span></a></li>
<li><a href="https://whatson.ae/section/well-being/beauty/" class="hover-nav"><span>Beauty</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/pets/" class="hover-nav"><span>Pets</span></a>
</li>
<li>
<a href="https://whatson.ae/section/shopping/" class="hover-nav"><span>Shopping</span></a>
</li>
<li>
<a href="https://whatson.ae/section/family/" class="hover-nav"><span>Family</span></a>
</li>
<li>
<a href="https://whatson.ae/section/competitions/" class="hover-nav"><span>Competitions</span></a>
</li>
<li><a href="https://whatson.ae/events/" class="hover-nav"><span>Events</span></a></li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>

<header class="header-mobile">
<div class="header-mobile__inner">
<div class="header-mobile__flex-row">
<div class="header-mobile__signup">
<a href=""><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/female-icon.svg" width="18" alt="account icon"></a>
</div>
<div class="header-mobile__logo-wrapper">
<a href="https://whatson.ae"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/wo-dubai.png" width="108" alt="logo icon"></a>
</div>
<div class="header-mobile__menu">
<a href="https://whatson.ae/knowledge/2990/newsletter-sign-up/" class="mobile__signup__btn">Sign up</a>
<div class="header-mobile__menu__inner">
<div class="header-mobile__menu__each"></div>
<div class="header-mobile__menu__each header-mobile__menu__each--wide"></div>
<div class="header-mobile__menu__each"></div>
</div>
</div>
</div>
<div class="header-mobile__menu__content">
<div class="header-mobile__menu__content__inner">
<div class="header-mobile__menu__content__inner">
<div class="header-mobile__menu__content__each ">
<a href="/section/news/">NEWS</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/eat/">EAT & DRINK</a>
 </div>
<div class="header-mobile__menu__content__each ">
<a href="/section/things-to-do/">THINGS TO DO</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/nightlife/">NIGHTLIFE</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/cinema/">CINEMA</a>
</div>
<div class="header-mobile__menu__content__each ">
<a href="/section/culture/">CULTURE</a>
</div>
</div>
<div class="header-mobile__menu__search-more">
<div class="header-mobile__menu__search">
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/search.svg" width="16" class="search__icon" alt="search icon">
</div>
<form role="search" method="get" action="https://whatson.ae" class="header-mobile__menu__search__form search__form__">
<input type="text" name="s" value="" placeholder="Search" class="header-mobile__menu__search__textbox">
</form>
<div class="header-mobile__menu__more">
<a href="">MORE &nbsp;<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/down-arrow-white-new.svg" width="12" class="more-down-btn" alt="more button icon"></a>
</div>
</div>
<div>
<ul class="header-mobile__nav-dropdown__sub-menu">
<li>
<a href="https://whatson.ae/section/culture/" class="hover-nav hover__dropdown"><span>Culture</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/culture/film/" class="hover-nav"><span>Film</span></a></li>
<li><a href="https://whatson.ae/section/culture/theatre/" class="hover-nav"><span>Theatre</span></a></li>
<li><a href="https://whatson.ae/section/culture/art/" class="hover-nav"><span>Art</span></a></li>
<li><a href="https://whatson.ae/section/culture/technology/" class="hover-nav"><span>Tech</span></a></li>
<li><a href="https://whatson.ae/section/culture/workshops/" class="hover-nav"><span>Workshops</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/travel/" class="hover-nav hover__dropdown"><span>Travel</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/travel/travel-deals/" class="hover-nav"><span>Deals</span></a></li>
<li><a href="https://whatson.ae/section/travel/staycations/" class="hover-nav"><span>Staycations</span></a></li>
<li><a href="https://whatson.ae/section/travel/short-haul/" class="hover-nav"><span>Short Haul</span></a></li>
<li><a href="https://whatson.ae/section/travel/long-haul/" class="hover-nav"><span>Long Haul</span></a></li>
</ul>
</li>
 <li>
<a href="https://whatson.ae/section/active/" class="hover-nav hover__dropdown"><span>Sports & Fitness</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/active/workouts/" class="hover-nav"><span>Workouts</span></a></li>
<li><a href="https://whatson.ae/section/active/indoor/" class="hover-nav"><span>Indoor</span></a></li>
<li><a href="https://whatson.ae/section/active/outdoor/" class="hover-nav"><span>Outdoor</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/well-being/" class="hover-nav hover__dropdown"><span>Wellbeing</span></a>
<img src="https://whatson.ae/wp-content/themes/whatson-grow/images/drop-down-arrow-white.svg" width="15" height="15" class="hover__dropdown__arrow__image" alt="more down icon">
<ul class="each__nav-dropdown__sub-menu">
<li><a href="https://whatson.ae/section/well-being/spas/" class="hover-nav"><span>Spas</span></a></li>
<li><a href="https://whatson.ae/section/well-being/beauty/" class="hover-nav"><span>Beauty</span></a></li>
</ul>
</li>
<li>
<a href="https://whatson.ae/section/pets/" class="hover-nav"><span>Pets</span></a>
</li>
<li>
<a href="https://whatson.ae/section/shopping/" class="hover-nav"><span>Shopping</span></a>
</li>
<li>
<a href="https://whatson.ae/section/family/" class="hover-nav"><span>Family</span></a>
</li>
<li>
<a href="https://whatson.ae/section/competitions/" class="hover-nav"><span>Competitions</span></a>
</li>
<li><a href="https://whatson.ae/events/" class="hover-nav"><span>Events</span></a></li>
</ul>
</div>
<div class="header-mobile___signup">
<div class="header-mobile___signup__btn">
SIGN UP & CUSTOMISE
</div>
</div>
</div>
</div>
</div>
</header>
<div class="article-content max-width">
<div style="position:absolute;left:-170px; width: 160px;height: 600px;" class="show__desktop">

<div id='div-gpt-ad-1604477721480-0' style='width: 160px; height: 600px;'>
<script>
                                    googletag.cmd.push(function() {  
                                        googletag.display('div-gpt-ad-1604477721480-0');                           
                                     });
                                  </script>
</div>
</div>
<div style="position:absolute; right:-170px; width: 160px;height: 600px;" class="show__desktop">

<div id='div-gpt-ad-1604477721480-1' style='width: 160px; height: 600px;'>
<script>
                                    googletag.cmd.push(function() {  
                                        googletag.display('div-gpt-ad-1604477721480-1');                             
                                     });
                                  </script>
</div>
</div>
<div class="article-content__inner">
<div class="article-content__flex-row">
<div class="article-content__left">

<div class="article-content__left__top">
<div class="article-content__image lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-feat.jpg)">
</div>

<h1 class="article-content__title">
<span class="outerSpan">
<span class="innerSpan">
10 awesome things you need to do this weekend: May 20 to 22 </span>
</span>
</h1>
</div>
<div class="article-content__meta">

<div class="article-content__social">
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="fb" data-link="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" data-picture="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-feat.jpg" data-name="10 awesome things you need to do this weekend: May 20 to 22" data-caption="10 awesome things you need to do this weekend: May 20 to 22" data-description="The weekend is almost upon us and it&#8217;s shaping up to be a big one&#8230; It&#8217;s Wednesday which means the weekend is just a day away and, if you&#8217;re anything&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/facebook.svg" width="38" alt="facebook follow"></a>
</div>
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="tw" data-link="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" data-picture="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-feat.jpg" data-name="10 awesome things you need to do this weekend: May 20 to 22" data-caption="10 awesome things you need to do this weekend: May 20 to 22" data-description="The weekend is almost upon us and it&#8217;s shaping up to be a big one&#8230; It&#8217;s Wednesday which means the weekend is just a day away and, if you&#8217;re anything&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/twitter.svg" width="38" alt="twitter follow"></a>
</div>
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="whatsapp" data-link="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" data-picture="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-feat.jpg" data-name="10 awesome things you need to do this weekend: May 20 to 22" data-caption="10 awesome things you need to do this weekend: May 20 to 22" data-description="The weekend is almost upon us and it&#8217;s shaping up to be a big one&#8230; It&#8217;s Wednesday which means the weekend is just a day away and, if you&#8217;re anything&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/whatsapp.svg" width="38" alt="whatsapp follow"></a>
</div>
<div class="article-content__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="mail" data-link="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" data-picture="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-feat.jpg" data-name="10 awesome things you need to do this weekend: May 20 to 22" data-caption="10 awesome things you need to do this weekend: May 20 to 22" data-description="The weekend is almost upon us and it&#8217;s shaping up to be a big one&#8230; It&#8217;s Wednesday which means the weekend is just a day away and, if you&#8217;re anything&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/mail.svg" width="38" alt="mail follow"></a>
</div>
</div>

<div class="article-content__tags article-content__tags--top">
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/things-to-do/best-of/">
Best of </a>
</div>
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/things-to-do/">
Things to do </a>
</div>
</div>

<div class="article-content__author">
<div class="article-content__author__image">
<img alt='Lauren Fletcher' src='https://whatson.ae/dubai/wp-content/uploads/2019/04/Lauren-Fletcher_avatar_1555833711.jpg' class='avatar avatar-45 photo' height='45' width='45' /> </div>
<div class="article-content__author__detail">
Written by: <br><strong> Lauren Fletcher </strong><br>
5 hours ago </div>
</div>
</div>

<div class="article-content__description">
<div class="article-text"><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"><h4>The weekend is almost upon us and it&rsquo;s shaping up to be a big one&hellip;</h4><p>It&rsquo;s Wednesday which means the weekend is just a day away and, if you&rsquo;re anything like us, we bet you&rsquo;re excited. Now that things are back to normal, with the <a href="https://whatson.ae/2021/05/dubai-ease-restrictions/" target="_blank" rel="noopener noreferrer">reintroduction of brunches and live entertainment</a>, we reckon this weekend is going to be huge.</p><p><strong>Here are 10 awesome things you need to do this weekend&hellip;&nbsp;</strong></p><h1>Thursday, May 20</h1><h3>Tuck into nine courses of stunning Thai cuisine for Dhs195</h3><div class="gallery__empty"></div><p><img class="alignnone size-full wp-image-176588" src="https://whatson.ae/wp-content/uploads/2020/10/Pai-Thai-welcomes-the-al-fresco-season.jpg" alt="Pai Thai welcomes the al fresco season" width="800" height="532"></p><p>Going out for an upmarket Thai meal can tend to get a little pricey, but during the <a href="https://whatson.ae/2021/05/tuck-into-nine-courses-of-stunning-thai-cuisine-for-dhs195-at-pai-thai/" target="_blank" rel="noopener noreferrer">summer Pai Thai has launched an amazing deal</a>, offering you nine courses of delicious Thai cuisine for just Dhs195 per person. You&rsquo;ll find the stunning restaurant at Jumeirah Al Qasr and it&rsquo;s well worth a visit.</p><p><em>Pai Thai, Jumeirah Al Qasr, Madinat Jumeirah, Dubai, Sunday to Thursday, 6pm to 11.30pm, Friday and Saturday, 12pm to 11.30pm, &lsquo;Siam Summer&rsquo; menu served daily, 6pm to 11.30pm, Dhs195. Tel: <span role="link" aria-label="Call phone number 800 666353">800 666353. <a href="https://www.jumeirah.com/en/dine/dubai/al-qasr-pai-thai?utm_source=google&amp;utm_medium=google%20places&amp;utm_campaign=restaurant" target="_blank" rel="noopener noreferrer">jumeirah.com</a></span></em></p><h3>Splash around in a waterpark at this Thursday ladies&rsquo; night</h3><p><img class="alignnone size-full wp-image-168751" src="https://whatson.ae/wp-content/uploads/2020/08/Laguna-waterpark.jpg" alt="Laguna waterpark" width="800" height="588"></p><div class="empty-ad"></div><p>The popular La Mer waterpark, Laguna Waterpark, is bringing back its popular ladies&rsquo; night from Thursday, May 20. It will run on May 20 and May 27 and every other week thereafter throughout June. Ladies, you&rsquo;ll have exclusive access to the entire waterpark.&nbsp;From 6pm to 12am you can explore the park at night. The park boasts hours of fun, with four zones named Surf, Relax, Slide and Splash.</p><p><em>Laguna Waterpark, La Mer, Dubai, Tues to Sun 10am to 6pm, closed Mondays, ladies&rsquo; nights open 6pm to 12am. Tel: 800 7699. <a href="https://www.lagunawaterpark.com/en" target="_blank" rel="noopener noreferrer">lagunawaterpark.com</a></em></p><h3>Go bowling</h3><p><img class="alignnone size-full wp-image-177117" src="https://whatson.ae/wp-content/uploads/2020/10/wavehouse-atlantis-the-palm.jpg" alt="wavehouse atlantis the palm" width="800" height="533"></p><p class="p2">Wavehouse at Atlantis, The Palm is a fine place for a game of tenpins. There&rsquo;s so much for everyone of any age to do: there&rsquo;s an enormous bar, a ping-pong area, multi-level arcade games, and soft play area for children &ndash; and that&rsquo;s just inside. Outside there&rsquo;s more seating, and a massive wave machine. It&rsquo;s become one of the most popular spots in Dubai for bowling, and for good reason.</p><p class="p2"><i>Atlantis, The Palm, from Dhs70 per person or Dhs420 per lane, per hour. Tel: (04) 4261166. <a href="https://www.atlantisthepalm.com/things-to-do/wavehouse">atlantisthepalm.com</a></i></p><h1>Friday, May 21</h1><h3>Enjoy breakfast with a side of sea views</h3><p><img class="alignnone size-full wp-image-200250" src="https://whatson.ae/wp-content/uploads/2021/05/jones-the-grocer-west-beach-article.jpg" alt="" width="800" height="533"></p><p>Start your weekend off right by enjoying <a href="https://whatson.ae/2021/05/amazing-dubai-breakfast-spots-with-stunning-sea-views/" target="_blank" rel="noopener noreferrer">breakfast with a side of sea views</a>. Jones the Grocer has long been popular for its artisan menu and cheese and wine offerings, and the new West Beach branch is the perfect place to start your day with beautiful sea and Dubai Marina skyline views. On the menu you&rsquo;ll find a traditional English breakfast, farmer&rsquo;s breakfast, &lsquo;classic benny&rsquo; and perfectly brewed coffees.</p><p><em>Jones The Grocer, West Beach, Palm Jumeirah, Dubai, open 8am to 12am daily. Tel: (0)54 998 6162. <a href="https://www.facebook.com/jonesthegrocerthepalm/?ref=page_internal" target="_blank" rel="noopener noreferrer">facebook.com/jonesthegrocerthepalm</a></em></p><h3>Check Reform&rsquo;s Eurovision-themed Friday brunch</h3><p><img class="alignnone size-full wp-image-195455" src="https://whatson.ae/wp-content/uploads/2021/03/pjimage-1-13.jpg" alt="reform social and grill" width="800" height="533"></p><p><a href="https://whatson.ae/2021/05/reform-is-throwing-a-eurovision-themed-long-friday-lunch/" target="_blank" rel="noopener noreferrer">Reform is throwing a fun Friday brunch</a> on May 21 to celebrate the Eurovision 2021 finale (which is happening on May 22). Enjoy three courses of traditional &lsquo;pub grub&rsquo; as well as free-flowing beverages, whilst being entertained by Jon Bessant and Em, as well as Mais Musica, who will be bowling out the tunes with hits from the likes of ABBA, Gina G, Katrina and the Waves. Dogs are welcome too.</p><p><em>The Best of Eurovision, Reform Social &amp; Grill, The Lakes, Dubai, Friday May 21, 1pm to 4pm, Dhs375 inclusive of free-flowing house beverages. Tel: (04) 454 2638. <a href="https://www.instagram.com/reformdubai/" target="_blank" rel="noopener noreferrer">@reformdubai</a></em></p><h3>Brunch inside the Burj Khalifa</h3><p><img class="alignnone size-full wp-image-200282" src="https://whatson.ae/wp-content/uploads/2021/05/0F0A1869.jpg" alt="" width="800" height="534"></p><p>Secret Parties are doing it again with a <a href="https://whatson.ae/2021/05/secret-parties-burj-khalifa/" target="_blank" rel="noopener noreferrer">brand new brunch in none-other than the Burj Khalifa</a>. Secret Brunch at the Burj Khalifa will take place in fancy restaurant 3BK and includes four-course meal along with free-flowing beverages. Menu highlights include sushi platters, roasted leg of lamb, seafood linguine, vegan lasagne and sweets such as eclairs, profiteroles and the special 3BK Khalifa Sundae.</p><p><em>Secret Brunch at the Burj Khalifa, 3BK, Burj Khalifa, Downtown Dubai, Fridays, 1pm to 4.30pm, from Dhs299. <a href="http://secret-parties.com" target="_blank" rel="noopener noreferrer">secret-parties.com</a></em></p><h3>Unearth hidden furniture treasures at this cool pop-up</h3><div class="instagram-feed"><blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 540px; min-width: 326px; padding: 0; width: calc(100% - 2px);" data-instgrm-permalink="https://www.instagram.com/p/CO-aMqxJdHZ/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="13">
<div style="padding: 16px;">
<p>&nbsp;</p>
<div style="display: flex; flex-direction: row; align-items: center;">
<div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;">
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div>
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div>
</div>
</div>
<div style="padding: 19% 0;"></div>
<div style="display: block; height: 50px; margin: 0 auto 12px; width: 50px;"></div>
<div style="padding-top: 8px;">
<div style="color: #3897f0; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: 550; line-height: 18px;">View this post on Instagram</div>
</div>
<div style="padding: 12.5% 0;"></div>
<div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;">
<div>
<div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div>
<div style="background-color: #f4f4f4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div>
<div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div>
</div>
<div style="margin-left: 8px;">
<div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div>
<div style="width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg);"></div>
</div>
<div style="margin-left: auto;">
<div style="width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div>
<div style="background-color: #f4f4f4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div>
<div style="width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div>
</div>
</div>
<div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;">
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div>
<div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div>
</div>
<p>&nbsp;</p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;"><a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none;" href="https://www.instagram.com/p/CO-aMqxJdHZ/?utm_source=ig_embed&amp;utm_campaign=loading" target="_blank" rel="noopener noreferrer">A post shared by La Brocante (@labrocantedxb)</a></p>
</div>
</blockquote></div><p><script async="" src="//www.instagram.com/embed.js"></script></p><p>If you&rsquo;re a big fan of upcycling and hunting down vintage furniture treasures, there&rsquo;s one place you need to be at this weekend. A La Brocante pop-up is taking place in Al Quoz, featuring unique vintage, pre-loved, and upcycled furniture, as well as clothes. It will also give local artists a chance to showcase their work. You might even get a chance to upcycle some furniture whilst you&rsquo;re there.</p><p><em>La Brocante, Al Quoz, Dubai, May 21 and 22, 10am to 5pm. <a href="https://www.instagram.com/labrocantedxb/" target="_blank" rel="noopener noreferrer">@labrocantedxb</a></em></p><h1>Saturday, May 22</h1><h3>Enjoy a roast dinner brunch with free-flowing beverages</h3><p><img class="alignnone size-full wp-image-192339" src="https://whatson.ae/wp-content/uploads/2021/02/SBG-VENUE-3.jpg" alt="Soho beer garden foxglove friday brunch" width="800" height="534"></p><p>Cool British gastropub Foxglove and the much-loved Soho Beer Garden have just launched the <a href="https://whatson.ae/2021/05/check-out-this-big-british-lunch-on-saturdays-with-unlimited-drinks-saturday-brunch/" target="_blank" rel="noopener noreferrer">&lsquo;Big British Lunch&rsquo; on Saturdays</a>, with a three-course meal and four hours of free-flowing beverages. It&rsquo;s the roast with the most and mains include Yorkshire pudding with pulled beef, roast&nbsp;leg of New Zealand&nbsp;lamb, and half roast chicken stuffed with sage and onions.</p><p><em>Foxglove Steakhouse and Gastropub and Soho Beer Garden, Meydan Racecourse, Big British Lunch, Saturdays, 2pm to 6pm, Dhs250 for ladies with house drinks, Dhs300 for gents with house drinks. Tel: (0) 52 388 8849. <a href="https://www.instagram.com/foxglovedxb/" target="_blank" rel="noopener noreferrer">@foxglovedxb</a></em></p><h3>Top up your tan at a fully-redeemable pool day</h3><p><img class="alignnone size-full wp-image-162640" src="https://whatson.ae/wp-content/uploads/2020/06/Best-swimming-pools-Zabeel-Saray.jpg" alt="Best-swimming-pools-Zabeel-Saray" width="800" height="533"></p><div class="article-content__you-may-like">
<h3>You might also like</h3>
<div class="article-content__you-may-like__each">
<a href="https://whatson.ae/2021/05/amazing-dubai-breakfast-spots-with-stunning-sea-views/" target="_blank">
Amazing Dubai breakfast spots with stunning sea views </a>
</div>
<div class="article-content__you-may-like__each">
<a href="https://whatson.ae/2021/05/dubai-ease-restrictions/" target="_blank">
Dubai bars reopen for vaccinated residents, brunches can resume </a>
</div>
</div><p>Before it gets too hot, carve out some time to work on that tan at a luxe Dubai pool. A Jumeirah Zabeel Saray Daily Splash Pass is Dhs200 from Sunday to Thursday, and Dhs250 on weekends, with the full amount redeemable on food and drinks.&nbsp; For children aged four to 12, it&rsquo;s Dhs125 on weekends and Dhs100 midweek. Under fours are free. On weekdays, you can enjoy breakfast plus access to the pool and beach for Dhs175.</p><p><em>Jumeirah Zabeel Saray, Palm Jumeirah. Bookings, visit:&nbsp;<a href="https://www.jumeirah.com/en/offers/category-offers/wellness/jumeirah-zabeel-saray/splash-pass-at-jumeirah-zabeel-saray" target="_blank" rel="noopener noreferrer">jumeirah.com</a></em></p><h3>Shop &rsquo;til you drop at the Ripe Market</h3><p><img class="alignnone size-full wp-image-167455" src="https://whatson.ae/wp-content/uploads/2020/07/ripe-market-inner.jpg" alt="ripe market" width="800" height="533"></p><p>With temperatures rising, Dubai&rsquo;s popular Ripe Market is heading indoors for the summer season. You can now find them at The Springs Souk, Nakheel Mall and Times Square Centre every weekend, plus monthly pop-up markets at the brand new <a href="https://whatson.ae/2021/04/community-mall-circle-mall-by-nakheel-in-jumeirah-village-circle-jvc-now-open/" target="_blank" rel="noopener noreferrer">Circle Mall located in JVC</a>. Discover a curated lineup of fashion, art, design and food products. Whether you&rsquo;re in the marketing for some new jewellery, decoration for your home, or a gift for a loved one, you&rsquo;re bound to find something unique.</p><p><em>The Ripe Market, various locations, Dubai. <a href="https://www.instagram.com/ripemarket/" target="_blank" rel="noopener noreferrer">@ripemarket</a></em></p><p><em>Images: Social/Provided</em></p></div><p></p>

<div class="article-content__sign-up">
<div class="article-content__sign-up__btn hover-opacity">
<a href="https://whatson.ae/knowledge/2990/newsletter-sign-up/">
Sign up!
</a>
</div>
<div class="article-content__sign-up__text">
> Sign up for FREE to get exclusive updates that you are interested in
</div>
</div>

<div class="article-content__footer-meta">
<div class="article-content__footer-meta__social">
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="fb" data-link="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" data-picture="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-feat.jpg" data-name="10 awesome things you need to do this weekend: May 20 to 22" data-caption="10 awesome things you need to do this weekend: May 20 to 22" data-description="The weekend is almost upon us and it&#8217;s shaping up to be a big one&#8230; It&#8217;s Wednesday which means the weekend is just a day away and, if you&#8217;re anything&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/facebook.svg" width="38" alt="facebook follow"></a>
</div>
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="tw" data-link="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" data-picture="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-feat.jpg" data-name="10 awesome things you need to do this weekend: May 20 to 22" data-caption="10 awesome things you need to do this weekend: May 20 to 22" data-description="The weekend is almost upon us and it&#8217;s shaping up to be a big one&#8230; It&#8217;s Wednesday which means the weekend is just a day away and, if you&#8217;re anything&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/twitter.svg" width="38" alt="twitter follow"></a>
</div>
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="whatsapp" data-link="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" data-picture="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-feat.jpg" data-name="10 awesome things you need to do this weekend: May 20 to 22" data-caption="10 awesome things you need to do this weekend: May 20 to 22" data-description="The weekend is almost upon us and it&#8217;s shaping up to be a big one&#8230; It&#8217;s Wednesday which means the weekend is just a day away and, if you&#8217;re anything&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/whatsapp.svg" width="38" alt="whatsapp follow"></a>
</div>
<div class="article-content__footer-meta__social__each hover-move-up">
<a href="javscript:void(0)" class="share-article" data-type="mail" data-link="https://whatson.ae/2021/05/10-awesome-things-you-need-to-do-this-weekend-may-20-to-22/" data-picture="https://whatson.ae/wp-content/uploads/2021/05/things-to-do-dubai-weekend-may-20-feat.jpg" data-name="10 awesome things you need to do this weekend: May 20 to 22" data-caption="10 awesome things you need to do this weekend: May 20 to 22" data-description="The weekend is almost upon us and it&#8217;s shaping up to be a big one&#8230; It&#8217;s Wednesday which means the weekend is just a day away and, if you&#8217;re anything&hellip;"><img src="https://whatson.ae/wp-content/themes/whatson-grow/images/mail.svg" width="38" alt="mail follow"></a>
</div>
</div>

<div class="article-content__footer-meta__tags">
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/things-to-do/best-of/" style="color:white; font-weight: 400;">
Best of </a>
</div>
<div class="article-content__tags__each hover-opacity">
<a href="https://whatson.ae/section/things-to-do/" style="color:white; font-weight: 400;">
Things to do </a>
</div>
</div>
</div>
</div>
</div>

<div class="article-content__right">

<div class="article-content--top-right-parent">
<div class="ad-wrapper article-content--top-right">
<div class="ad-wrapper__inner add__with__bg">
<div class="ad-wrapper__300x250">

<div class="">

<div id='div-gpt-ad-1594287178696-0'>
<script>
                                                googletag.cmd.push(function() { 
                                                    googletag.display('div-gpt-ad-1594287178696-0'); 
                                                });
                                            </script>
</div>
</div>
</div>
</div>
</div>
</div>

<div class="special-articles special-articles--right-side editors-pick__styl2">
<div class="article-content__title-without-bg">
<div class="article-content__title-without-bg__text">EDITOR’S PICKS</div>
</div>
<div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/05/so-when-is-the-next-uae-public-holiday-in-2021/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/02/dubai-general-skyline-featured.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/05/so-when-is-the-next-uae-public-holiday-in-2021/">
<span class="outerSpan">
<span class="innerSpan">
So, when is the next UAE public holiday in 2021?
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/05/so-when-is-the-next-uae-public-holiday-in-2021/">READ MORE</a>
</div>
</div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/05/all-of-the-hotels-set-to-open-in-dubai-in-2020/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2021/05/lavish-hotels-in-2021.1.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/05/all-of-the-hotels-set-to-open-in-dubai-in-2020/">
<span class="outerSpan">
<span class="innerSpan">
All of the lavish new hotels set to open in Dubai in 2021
</span>
</span>
 </a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/05/all-of-the-hotels-set-to-open-in-dubai-in-2020/">READ MORE</a>
</div>
</div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/05/fully-redeemable-pool-passes-in-dubai/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2020/11/dubai-pool-passes-redeemable.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/05/fully-redeemable-pool-passes-in-dubai/">
<span class="outerSpan">
<span class="innerSpan">
16 of the best pool passes in Dubai that are fully redeemable
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/05/fully-redeemable-pool-passes-in-dubai/">READ MORE</a>
</div>
</div>
<div class="each-article each-article--article-detail">
<div class="each-article__image">
<a href="https://whatson.ae/2021/05/all-the-new-restaurants-set-to-open-at-palm-west-beach-palm-jumeirah/" class="lazy" data-bg="url(https://whatson.ae/wp-content/uploads/2020/10/Palm-West-Beach-feat.jpg)">
</a>
</div>
<div class="each-article__title">
<a href="https://whatson.ae/2021/05/all-the-new-restaurants-set-to-open-at-palm-west-beach-palm-jumeirah/">
<span class="outerSpan">
<span class="innerSpan">
All of the restaurants at West Beach, Palm Jumeirah
</span>
</span>
</a>
</div>
<div class="each-article__button hover-opacity">
<a href="https://whatson.ae/2021/05/all-the-new-restaurants-set-to-open-at-palm-west-beach-palm-jumeirah/">READ MORE</a>
</div>
</div>
</div>
</div>

<div class="ad-wrapper">
<div class="ad-wrapper__inner add__with__bg">
<div class="ad-wrapper__300x600">

<div class="">
<div id='div-gpt-ad-1564915739711-0'>
<script>
                                            googletag.cmd.push(function() { 
                                                googletag.display('div-gpt-ad-1564915739711-0'); 
                                            });
                                        </script>
</div>
</div>
</div>
</div>
</div>

<div class="special-articles--right-side">
<div class="special-articles">
<div class="special-articles__title">
<span>MOST POPULAR</span>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/05/seven-sisters-dubai-returns/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/05/sevensistersdubai.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/05/seven-sisters-dubai-returns/">
Seven Sisters Dubai is back with a brand new look </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/05/dubais-longest-happy-hours/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/03/UBK-featured-2.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/05/dubais-longest-happy-hours/">
Dubai's longest happy hours: park yourself at these Dubai bars </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/05/yava-wasl-51/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/05/Yava-featured.jpg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/05/yava-wasl-51/">
A new Mediterranean restaurant has opened at Wasl 51 </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/05/7-amazing-things-to-do-in-abu-dhabi-this-weekend-may-20-to-22/" style="background-image: url(https://whatson.ae/wp-content/uploads/2020/07/Abu-Dhabi-Skyline-Feat.jpeg)">
</a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/05/7-amazing-things-to-do-in-abu-dhabi-this-weekend-may-20-to-22/">
7 amazing things to do in Abu Dhabi this weekend: May 20 to 22 </a>
</div>
</div>
</div>
<div class="special-articles__each">
<div class="flex-row">
<div class="special-articles__image">
<div class="special-articles__image__container">
<a href="https://whatson.ae/2021/05/festival-plaza-book-club-may-2021/" style="background-image: url(https://whatson.ae/wp-content/uploads/2021/05/bokclub.jpg)">
 </a>
</div>
</div>
<div class="special-articles__descp">
<a href="https://whatson.ae/2021/05/festival-plaza-book-club-may-2021/">
Connect with other readers this May at The Festival Plaza Book Club </a>
</div>
</div>
</div>
</div>
</div>

<div class="checkArticleHalfpage"></div>
<div class="ad-wrapper second__MPU hp_floatAd">
<div class="ad-wrapper__inner add__with__bg">
<div class="ad-wrapper__300x250">

<div class="">
<div id='div-gpt-ad-1564915694174-0'>
<script>
                                            googletag.cmd.push(function() { 
                                                googletag.display('div-gpt-ad-1564915694174-0'); 
                                            });
                                        </script>
</div>
</div>
</div>
</div>
</div>
</div>
</div>

<div class="article-content__title-without-bg you__should__also">
<div class="article-content__title-without-bg__text">YOU SHOULD CHECK OUT</div>
</div>
<div class="load__home__content" data-category="things-to-do">
</div>
</div> 
</div> 
<footer>
</footer>
</div> 
</div> 
<footer class="footer__wrapper">
<div class="footer__wrapper__inner max-width">
<div class="footer__menu">
<div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-824" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-824"><a href="https://whatson.ae/about/advertising/">Advertise with us</a></li>
<li id="menu-item-825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-825"><a href="https://whatson.ae/about/legal/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-827" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-827"><a href="https://whatson.ae/about/">About Motivate</a></li>
</ul></div> </div>
<div class="footer__copyright">
<p class="">Motivate Media Group © 2021</p>
</div>
</div>
</footer>
<div id='fb-pxl-ajax-code'></div><script type='text/javascript'>
/* <![CDATA[ */
var ctcc_vars = {"expiry":"30","method":"1","version":"1"};
/* ]]> */
</script>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/60ad6.js"></script>
<script type="text/javascript">
					jQuery(document).ready(function($){
												if(!catapultReadCookie("catAccCookies")){ // If the cookie has not been set then show the bar
							$("html").addClass("has-cookie-bar");
							$("html").addClass("cookie-bar-bottom-bar");
							$("html").addClass("cookie-bar-bar");
													}
																	});
				</script>
<div id="catapult-cookie-bar" class=""><div class="ctcc-inner "><span class="ctcc-left-side">Our website uses cookies and other similar technologies to improve our site and your online experience. By continuing to use our website you consent to cookies being used. <a class="ctcc-more-info-link" tabindex=0 target="_blank" href="https://whatson.ae/about/legal/privacy-policy/">Read our privacy policy here.</a></span><span class="ctcc-right-side"><button id="catapultCookie" tabindex=0 onclick="catapultAcceptCookies();">Okay, thanks</button></span></div></div>
<script type="text/javascript">
    adroll_adv_id = "J636N26HTRH3HF2B3FJ6YO";
    adroll_pix_id = "RKAQBLXCRBAWDEYT7X6FNW";
    (function () {
        var oldonload = window.onload;
        window.onload = function(){
            __adroll_loaded=true;
            var scr = document.createElement("script");
            var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
            scr.setAttribute('async', 'true');
            scr.type = "text/javascript";
            scr.src = host + "/j/roundtrip.js";
            ((document.getElementsByTagName('head') || [null])[0] ||
             document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
            if(oldonload){oldonload()}};
    }());
</script>
<script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
<script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>
<script src="https://tags.crwdcntrl.net/c/8987/cc_af.js"></script>
<img src="//qa-gmtdmp.mookie1.com/t/v2/learn?tagid=V2_10308&src.rand=[timestamp]&src.id=[optionally replace with unique identifier]" style="display:none;" />
<script type="text/javascript">
    adroll_adv_id = "J636N26HTRH3HF2B3FJ6YO";
    adroll_pix_id = "RKAQBLXCRBAWDEYT7X6FNW";
    (function () {
    var oldonload = window.onload;
    window.onload = function(){
       __adroll_loaded=true;
       var scr = document.createElement("script");
       var host = (("https:" == document.location.protocol) ? "https://s.adroll.com" : "http://a.adroll.com");
       scr.setAttribute('async', 'true');
       scr.type = "text/javascript";
       scr.src = host + "/j/roundtrip.js";
       ((document.getElementsByTagName('head') || [null])[0] ||
        document.getElementsByTagName('script')[0].parentNode).appendChild(scr);
       if(oldonload){oldonload()}};
    }());
</script>
<script type="text/javascript" src="https://whatson.ae/wp-content/cache/minify/7a133.js"></script>
<script type="text/javascript" class="teads" async="true" src="//a.teads.tv/page/106581/tag"></script>
</body></html>
